Bug 1502603 - Validation fails with no output or error message to indicate what's wrong
Summary: Validation fails with no output or error message to indicate what's wrong
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
: ---
Assignee: Florian Fuchs
QA Contact: Ola Pavlenko
Depends On:
Blocks: 1440464
TreeView+ depends on / blocked
Reported: 2017-10-16 10:18 UTC by Udi Kalifon
Modified: 2018-02-01 12:52 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2018-02-01 12:52:14 UTC
Target Upstream Version:

Attachments (Terms of Use)
The plan file (388.25 KB, application/x-gzip)
2017-10-16 10:18 UTC, Udi Kalifon
no flags Details
screenshot (143.82 KB, image/png)
2017-10-16 10:20 UTC, Udi Kalifon
no flags Details

Description Udi Kalifon 2017-10-16 10:18:50 UTC
Created attachment 1339154 [details]
The plan file

Description of problem:
I ran the validator "Validate the Heat environment file for network configuration" and it failed. Besides the status "failed" there is nothing to indicate what's broken in my configuration. This is actually a configuration that I expected to work.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Use the attached plan file and upload to the GUI
2. Run the network-environment validator

Actual results:
Fail with no reason. See attached screen shot.

Expected results:
A clear indication where the configuration is broken.

Comment 1 Udi Kalifon 2017-10-16 10:20:29 UTC
Created attachment 1339155 [details]

Comment 2 Udi Kalifon 2017-10-16 14:30:23 UTC
Sorry!! This bug is more general and affects all the validations that you run (not just the network-environment validator). 

When you run the validators from the command line most of them pass, so it's a GUI problem that they fail when you run them from the GUI.

The network-environment validator, specifically, fails from the command line as well due to an issue with utf-8 (a known issue which is being worked on). The GUI should show the error as well when it happens.

Comment 6 Udi Kalifon 2018-02-01 12:52:14 UTC
This issue is already resolved.

Note You need to log in before you can comment on or make changes to this bug.