Bug 1502851 - [RFE] [Sahara] CLI for Plugin-Declared Image Generation for Ambari 2.4
Summary: [RFE] [Sahara] CLI for Plugin-Declared Image Generation for Ambari 2.4
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Telles Nobrega
QA Contact: Luigi Toscano
URL:
Whiteboard:
Depends On:
Blocks: 1337661
TreeView+ depends on / blocked
 
Reported: 2017-10-16 20:27 UTC by Telles Nobrega
Modified: 2018-06-27 13:38 UTC (History)
5 users (show)

Fixed In Version: openstack-sahara-8.0.1-0.20180228170523.abcc07a.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:37:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 448714 None master: MERGED sahara: Image generation for Ambari Plugin (I0e798696de7fb2fcf72d826ad6b7356f526db836) 2018-03-21 13:33:35 UTC
OpenStack gerrit 544625 None stable/queens: MERGED sahara: Adding Ambari 2.4.2.0 to image gen (I272dbab4458c902af404a6365a8a43d56e4ed94e) 2018-03-21 13:33:29 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:31 UTC

Description Telles Nobrega 2017-10-16 20:27:34 UTC
Description of problem:

This is a subset of a major bug #1337661. 

This is specific for Ambari plugin version 2.4

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Luigi Toscano 2018-02-19 15:46:47 UTC
The implementation is a bit different than what happens with the sahara-image-elements generation: we are going to use a unified Ambari 2.4 image to deploy HDP 2.4 and 2.3. The title of the feature is a bit confusing because it conflates together the version of Ambari and the version of the deployed HDP. Right now sahara-image-elements deploys Ambari 2.2.1.0 for HDP 2.4 and Ambari 2.2.0.0 for HDP 2.3, but there is no reason for it, because Ambari 2.4 can deploy both those older versions (and also HDP 2.5, but let's put that aside).
See https://review.openstack.org/#/c/544625/ too.

Comment 7 Luigi Toscano 2018-04-23 17:01:36 UTC
The image generated with Ambari 2.4 can spawn HDP 2.4 clusters and run jobs.

Tested with 
openstack-sahara-8.0.1-0.20180328233736.36531cb

Comment 9 errata-xmlrpc 2018-06-27 13:37:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.