Bug 1502966 - DNF hangs on installing phpmyadmin package.
Summary: DNF hangs on installing phpmyadmin package.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: phpMyAdmin
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Remi Collet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1485740 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-17 06:48 UTC by Haghighi
Modified: 2017-11-15 17:40 UTC (History)
13 users (show)

Fixed In Version: phpMyAdmin-4.7.5-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-15 17:40:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Haghighi 2017-10-17 06:48:48 UTC
DNF hangs on installing phpmyadmin package.
Other packages installed with no problem. 
I'm also removed all the cached data, but problem still exist.


DNF output:
===========  
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
Preparing        : 
Reinstalling     : phpMyAdmin-4.7.4-1.fc27.noarch
Running scriptlet: phpMyAdmin-4.7.4-1.fc27.noarch

Comment 1 Remi Collet 2017-10-17 08:00:09 UTC
The scriplet read /dev/urandom... perhaps can explain this.

@Haghighi can you test (which use another simpler version of the scriptlet)

dnf install https://rpms.remirepo.net/fedora/27/remi/x86_64/phpMyAdmin-4.7.4-1.fc27.remi.noarch.rpm

Comment 2 Robert Scheck 2017-10-17 08:04:09 UTC
Haghighi, what environment is that? If the environment is not able to
provide 32 byte of entropy in a reasonable time...well, I'm honestly not
sure if such an environment is suitable for anything at all. But yes,
the testing result from Remi's package would still be interesting.

Comment 3 Remi Collet 2017-10-17 08:06:59 UTC
@Robert, the simpler scriptlet use

SECRET=$(printf "%04x%04x%04x%04x%04x%04x%04x%04x" $RANDOM $RANDOM $RANDOM $RANDOM $RANDOM $RANDOM $RANDOM $RANDOM)

(which still, of course, requires some entropy)

Comment 4 Haghighi 2017-10-17 08:20:24 UTC
(In reply to Remi Collet from comment #1)
> The scriplet read /dev/urandom... perhaps can explain this.
> 
> @Haghighi can you test (which use another simpler version of the scriptlet)
> 
> dnf install
> https://rpms.remirepo.net/fedora/27/remi/x86_64/phpMyAdmin-4.7.4-1.fc27.remi.
> noarch.rpm

Remi's package installed correctly. and works fine.

Comment 5 Robert Scheck 2017-10-17 08:27:33 UTC
Now I am even more interested what kind of environment that is. At least
it does not seem to provide reliable entropy. Is that a container?

Comment 6 Haghighi 2017-10-17 10:05:20 UTC
(In reply to Robert Scheck from comment #5)
> Now I am even more interested what kind of environment that is. At least
> it does not seem to provide reliable entropy. Is that a container?

No
It is a normal PC
Intel® Core™ i5-2500K CPU @ 3.30GHz × 4 
Fedora workstation 27 x86_64
Linux 4.13.5-300.fc27.x86_64

Comment 7 Hedayat Vatankhah 2017-10-18 10:13:18 UTC
(In reply to Remi Collet from comment #1)
> The scriplet read /dev/urandom... perhaps can explain this.
> 
I'm I wrong that reading from /dev/urandom is supposed to never block?

Comment 8 Remi Collet 2017-10-24 03:28:52 UTC
@Robert see negative comment on https://bodhi.fedoraproject.org/updates/FEDORA-2017-228d6fddb5

Comment 9 Remi Collet 2017-10-24 04:55:01 UTC
*** Bug 1485740 has been marked as a duplicate of this bug. ***

Comment 10 Remi Collet 2017-10-24 04:58:14 UTC
@Robert, I was able to reproduce on a fresj F27 VM, fully updated, and then dnf install phpMyAdmin (4.7.4 or 4.7.5)

Comment 12 Heldwin 2017-10-24 22:16:27 UTC
@Remi, thanks, with this change it doesn't trigger the hang.

Interestingly, it was not triggering this hang if I ran the command of the scriptlet manually (I don't even have time to see the processes), but was doing it only in dnf.

It was doing it with downgrade, upgrade, and reinstall. 
Even if there was not MUSTBECHANGEDONINSTALL in the config file.

In top, there were all (cat/tr/fold) switching between status: R (running) and S (sleeping), but fold was the one the most active and was using 55% to 95% of my core2duo (even while sleeping).

Comment 13 Fedora Update System 2017-10-25 15:23:00 UTC
phpMyAdmin-4.7.5-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-228d6fddb5

Comment 14 Haghighi 2017-10-26 12:21:34 UTC
Problem solved in phpMyAdmin-4.7.5-2.fc27
Thank you all

Comment 15 Robert Scheck 2017-10-29 21:25:36 UTC
Just asking...without having this verified: Could it be that SELinux is
blocking access to /dev/urandom when called by RPM?

Comment 16 George R. Goffe 2017-10-29 22:13:23 UTC
Robert,

In my case, I have SELINUX "disabled" in the /etc/selinux/config file. That doesn't mean that selinux couldn't be involved though... parts of selinux could be checking incorrectly and "think" that selinux IS active when it is NOT.

Regards,

George...

Comment 17 Robert Scheck 2017-10-29 22:44:16 UTC
So it's not SELinux specific, thanks George for letting us know.

Comment 18 Nathan O'Brennan 2017-11-14 21:25:21 UTC
Is phpMyAdmin-4.7.5-2.fc27 going to be available for F27 launch? I have several systems which are now hung dead during install because of phpMyAdmin. I have killed the fold process in the background to continue with the installs, but this should have been fixed by release, right?

Comment 19 Remi Collet 2017-11-15 06:21:40 UTC
@Nathan, the bug status in still "ON_QA", so not yet in the stable repository.

Comment 20 Fedora Update System 2017-11-15 17:40:08 UTC
phpMyAdmin-4.7.5-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.