Bug 1502970 - Unchanged upstream tendrl-ansible in downstream repo
Summary: Unchanged upstream tendrl-ansible in downstream repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ansible
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Timothy Asir
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks: 1460574
TreeView+ depends on / blocked
 
Reported: 2017-10-17 06:54 UTC by Daniel Horák
Modified: 2017-12-18 04:39 UTC (History)
6 users (show)

Fixed In Version: tendrl-ansible-1.5.4-1.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
example of suggested upstream changes for rpm specfile (2.70 KB, patch)
2017-10-17 14:18 UTC, Martin Bukatovic
no flags Details | Diff
example of suggested upstream changes for site.yml.sample playbook (838 bytes, patch)
2017-10-17 14:20 UTC, Martin Bukatovic
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Description Daniel Horák 2017-10-17 06:54:23 UTC
Description of problem:
  The tendrl-ansible package[1] have no changes related to downstream and contains (only) upstream related files.

Version-Release number of selected component (if applicable):
  tendrl-ansible-1.5.3-2.el7rhgs

How reproducible:
  100%

Actual results:
  For example tendrl repo points to copr and grafana repo points to upstream repository:
  
  # cat /usr/share/ansible/roles/tendrl-ansible.tendrl-copr/files/tendrl-release-epel-7.repo
  [tendrl-release]
  name=Copr repo for release owned by tendrl
  baseurl=https://copr-be.cloud.fedoraproject.org/results/tendrl/release/epel-7-$basearch/
  ...

  # cat /usr/share/ansible/roles/tendrl-ansible.grafana-repo/files/grafana.repo
  [grafana]
  name=grafana
  baseurl=https://packagecloud.io/grafana/stable/el/6/$basearch
 ...


Expected results:
  Downstream tendrl-ansible package should not contain upstream only related content and should be updated for downstream installation.

Additional info:

[1] https://brewweb.engineering.redhat.com/brew/buildinfo?buildID=608075

Comment 3 Martin Bukatovic 2017-10-17 14:18:14 UTC
Created attachment 1339732 [details]
example of suggested upstream changes for rpm specfile

Comment 4 Martin Bukatovic 2017-10-17 14:20:58 UTC
Created attachment 1339733 [details]
example of suggested upstream changes for site.yml.sample playbook

Comment 5 Martin Bukatovic 2017-10-17 14:29:23 UTC
I suggest at least to drop roles ceph-installer, gluster-gdeploy-copr, grafana-repo and tendrl-copr in the downstream package. We would need to do this via patch against pristine upstream release source tarball.

This means that we need to:

1) Remove references to these roles in downstream specfile (see example of suggested change of upstream specfile in attachment 1339732 [details]).

2) Moreover we would need to maintain a patch of upstream example playbook site.yml.sample, so that it would not contain references to these roles (see example of suggested change in attachment 1339733 [details]). This patch needs to be added into dist git repo and referenced in downstream specfile (via Patch0: and related %patch0 during %prep) to be applied during rpmbuild.

Comment 8 Timothy Asir 2017-11-02 19:11:48 UTC
Done the required changes in the spec file and taken patch2 and build the package tendrl-selinux version 1.5.3-3 and updated the repo.

Comment 13 errata-xmlrpc 2017-12-18 04:39:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.