Bug 1503022 - ipa-getkeytab man page should have more details about consequences of krb5 key renewal
Summary: ipa-getkeytab man page should have more details about consequences of krb5 ke...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-17 08:19 UTC by Thorsten Scherf
Modified: 2018-04-10 16:49 UTC (History)
7 users (show)

Fixed In Version: ipa-4.5.4-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 16:48:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0918 None None None 2018-04-10 16:49:12 UTC

Description Thorsten Scherf 2017-10-17 08:19:36 UTC
Description of problem:

The 'ipa-getkeytab' tool is used to retrieve a kerberos keytab from the server. The man page contains a warning that retrieving the keytab resets the secret for the Kerberos principal and that this renders all other keytabs for that principal invalid.

Some more details why resetting the key in a replicated environment might be not the best idea should be added to the man page.

https://www.freeipa.org/page/V4/Keytab_Retrieval can be used as a reference.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Florence Blanc-Renaud 2017-11-07 08:29:20 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/7237

Comment 3 Standa Laznicka 2017-11-08 07:01:24 UTC
Fixed upstream
master:
https://pagure.io/freeipa/c/8b8437aa7342a79169913c886af4ac35f253aee2

Comment 4 Standa Laznicka 2017-11-08 09:51:54 UTC
Fixed upstream
ipa-4-5:
https://pagure.io/freeipa/c/1f7ffb1ad0d4f5769494ae69a828788a5b90e6db

Comment 5 Standa Laznicka 2017-11-09 11:10:10 UTC
Fixed upstream
ipa-4-6:
https://pagure.io/freeipa/c/e76ab3e8b08a4b4d08f05208117be38e383fa0a6

Comment 7 Mohammad Rizwan 2018-01-18 10:05:46 UTC
version:
ipa-server-4.5.4-8.el7.x86_64

steps:
1. $ man ipa-getkeytab

Actual result:

[..]
WARNING:  retrieving the keytab resets the secret for the Kerberos principal.  This renders all other keytabs for that principal invalid.  When multiple hosts or
       services need to share the same key (for instance in high availability or load balancing clusters), the -r option must be  used  to  retrieve  the  existing  key
       instead of generating a new one (please refer to the EXAMPLES section).

       Note  that  the  user or host calling ipa-getkeytab needs to be allowed to generate the key with ipa host-allow-create-keytab or ipa service-allow-create-keytab,
       and the user or host calling ipa-getkeytab -r needs to be allowed to retrieve the keytab for the host or service with ipa host-allow-retrieve-keytab or ipa  ser‐
       vice-allow-retrieve-keytab.
[..]


Based on above observations, marking the bug as verified.

Comment 10 errata-xmlrpc 2018-04-10 16:48:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0918


Note You need to log in before you can comment on or make changes to this bug.