Bug 150310 - Can mount multiple logical volumes to single mount point
Summary: Can mount multiple logical volumes to single mount point
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 4.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Alasdair Kergon
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-04 16:08 UTC by Garret Davis
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-08 14:45:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Garret Davis 2005-03-04 16:08:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; .NET CLR 1.1.4322)

Description of problem:
I can create 2 logical volumes and moount them both to the same mount point, to me this is a bug that needs fixing.

Example:

lvcreate -L 500 /dev/vg00 - creates lvol1
lvcreate -L 1500 /dev/vg00 - creates lvol2

So now you have /dev/vg00/lvol1 and /dev/vg00/lvol2

mkdir /test

mount /dev/vg00/lvol /test
mount /dev/vg00/lvol2 /test

then do a df...you have to volumes mounted at /test with different lvol's

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See Description
2.
3.
  

Actual Results:  See Description

Expected Results:  Error out saying volume is already in use

Additional info:

Comment 1 Alasdair Kergon 2005-03-08 14:45:02 UTC
That's how mount works in unix, letting you stack filesystems over each other.

Comment 2 Garret Davis 2005-03-08 15:14:41 UTC
I have done my testing and it does not work that way on all Unix's...AIX and 
Linux do it this way, but HP and Sun have fixed this from happening. As for it 
being a bug, maybe it's not cause so many people like yourself have let it 
slide as "that's the way it has always been". If HP and Sun fixed it, it was 
for a reason, and I believe the reason it because people accidently fat finger 
things on a regular basis.

Are you saying Red Hat is not going to fix this in THIER logical volume 
manager? I see you closed the ticket saying this is not a bug, could you 
please put in more the "That's how mount works in unix, letting you stack 
filesystems over each other" as a reason for closing this ticket.

Comment 3 Alasdair Kergon 2005-03-08 17:04:53 UTC
This is nothing to do with lvm2.

See the mount(2) man page or use google for background.



Note You need to log in before you can comment on or make changes to this bug.