Bug 150321 - Fix ConfigUploadAction, Add test
Fix ConfigUploadAction, Add test
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ken Ganong
Red Hat Satellite QA List
:
Depends On:
Blocks: rhnMilestone1
  Show dependency treegraph
 
Reported: 2005-03-04 11:45 EST by Ken Ganong
Modified: 2007-04-18 13:20 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-08 08:52:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2005-03-04 11:45:12 EST
ConfigUploadAction has two ActionChildren, ConfigDateDetails and
ConfigDateFileAction.  Both use actionId as a primary key.  This
should work for ConfigDateDetails (test will indicate that problem),
but it will not work for ConfigDateFileAction because
ConfigUploadAction contains a set of them, meaning multiple
ConfigDateFileActions with the same primary key.

There needs to be a test for creating, committing, and looking up a
ConfigUploadAction.
Comment 1 Ken Ganong 2005-03-04 15:15:22 EST
Correct, three ActionChildren,  ConfigChannelAssociation.  This third
one also has no mapping file.
Comment 2 Ken Ganong 2005-03-08 08:52:34 EST
Tested whether ConfigUploadActions could be created, committed, and
looked up.  Added a composite key to ConfigDateFileAction.  Found that
the equals method of ConfigChannelAssociation wouldn't allow the
lookup of more than one ConfigChannelAssociation and fixed that. 
ConfigChannelAssociations mapping is achieved through a composite key
in Action.hbm.xml.

Note You need to log in before you can comment on or make changes to this bug.