Bug 1503227 - [RFE] Changelog option in a gluster volume disables with no warning if geo-rep is configured
Summary: [RFE] Changelog option in a gluster volume disables with no warning if geo-re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kotresh HR
QA Contact:
URL:
Whiteboard:
Depends On: 1498391
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-17 15:31 UTC by Kotresh HR
Modified: 2018-03-15 11:18 UTC (History)
8 users (show)

Fixed In Version: glusterfs-4.0.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1498391
Environment:
Last Closed: 2018-03-15 11:18:57 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2017-10-17 15:31:09 UTC
+++ This bug was initially created as a clone of Bug #1498391 +++

Description of problem:
------------------------
When disabling changelog for a volume which is participating in the geo-replication, there should be a clear warning that this could affect the geo-replication session in which that particular volume is participating. 
Changelog currently disables with no warning. 

[root@dhcp42-35 ~]# gluster volume set master changelog.changelog off
volume set: success
[root@dhcp42-35 ~]# 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
mainline

Comment 1 Worker Ant 2017-10-17 15:33:18 UTC
REVIEW: https://review.gluster.org/18540 (glusterd: Validate changelog on geo-rep volume) posted (#1) for review on master by Kotresh HR (khiremat@redhat.com)

Comment 2 Worker Ant 2017-11-12 06:50:37 UTC
COMMIT: https://review.gluster.org/18540 committed in master by  

------------- glusterd: Validate changelog on geo-rep volume

If geo-rep is configured on volume, don't allow
to disable changelog.

Change-Id: I7d1ba8b2939c8fe6ee6c59fb923d9aa1bdab553c
BUG: 1503227
Signed-off-by: Kotresh HR <khiremat@redhat.com>

Comment 3 Atin Mukherjee 2017-11-12 06:58:59 UTC
The patch actually disallows this to happen. So there is a discrepency between what the patch does and what the bugzilla problem description says. I realized this after merging the patch. Is my understanding correct that we should disallow it? If so then the text has to be corrected here.

Comment 4 Kotresh HR 2017-11-21 06:21:16 UTC
If geo-rep session is established, we should not allow the changelog to disable. 
Disable and enabling it during the same session could cause geo-rep not to sync data.

Comment 5 Shyamsundar 2018-03-15 11:18:57 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.0.0, please open a new bug report.

glusterfs-4.0.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-March/000092.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.