Bug 150331 - gcc4 miscompiles gnome-menus
gcc4 miscompiles gnome-menus
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-04 12:12 EST by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-04 14:57:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2005-03-04 12:12:58 EST
gcc4 seems to miscompile gnome-menus at least on x86_64. The problem goes
away if an if-else with two identical branches is replaced by just the 
branch code.


http://bugzilla.gnome.org/show_bug.cgi?id=169200 has stacktraces and the patch

Tell me if you need any other details.
Comment 1 Matthias Clasen 2005-03-04 13:03:49 EST
Sorry, the if-else idea was just me being shortsighted. The problem is actually
that cached_dir_add_entry is miscompiled, so that dir is valid at the entry of
the function, but when we try to access dir-entries later dir is NULL.

I have been unsuccessful in reducing this to a standalone testcase so far.
Comment 2 Matthias Clasen 2005-03-04 14:57:58 EST
Turned out to be an unrelated 64bit problem

Note You need to log in before you can comment on or make changes to this bug.