Bug 1503477 - [RFE] Organization-title option is missing for hammer-cli-katello commands
Summary: [RFE] Organization-title option is missing for hammer-cli-katello commands
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hammer - Content
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Roman Plevka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-18 08:41 UTC by Stanislav Tkachenko
Modified: 2019-06-03 12:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 12:05:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 21375 0 None None None 2017-10-18 08:52:42 UTC

Description Stanislav Tkachenko 2017-10-18 08:41:03 UTC
Description of problem:
Taxonomy titles were added in https://github.com/theforeman/hammer-cli-foreman/pull/299
However, accordint to @tstrachota hammer-cli-katello overrides setting for such organization related options across the plugin, so `location-title` is present while `organization-title` is missing. For example, `hammer host-collection hosts --help`

Version-Release number of selected component (if applicable):
Satellite 6.3 Snap 20:
* satellite-6.3.0-20.0.beta.el7sat.noarch
* katello-3.4.5-4.el7sat.noarch
* foreman-1.15.4.8-1.el7sat.noarch
* tfm-rubygem-hammer_cli_foreman-0.11.0.1-1.el7sat.noarch
* tfm-rubygem-hammer_cli_katello-0.11.0-1.el7sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. hammer host-collection hosts --help
2. Check whether both location-title and organization-title are present
3.

Actual results:
--location-title is available.
--organization-title is missing.

Expected results:
Options for both taxonomy titles are present.

Additional info:

Comment 2 Bryan Kearney 2019-05-02 19:06:48 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2019-06-03 12:05:31 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.