Bug 150391 - Printing text to a broadcast share does not respect margins
Printing text to a broadcast share does not respect margins
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-05 07:15 EST by Sitsofe Wheeler
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-26 11:50:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2005-03-05 07:15:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041009 Firefox/1.0

Description of problem:
(I suspect that this is cups problem rather than system-config-printer but system-config-printer shows the problem up really well).

If you print a text file to a remote printer share the page set up and margins do not seem to be respected and text is "invisibly" printed outside of margins.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116.1.1-1

How reproducible:
Always

Steps to Reproduce:
1. On the machine with the printer attached run system-config-printer .
2. Select the printer and print an ASCII text test page .
3. Ensure that the printer is shared .
4. On another machine run system-config-printer .
5. Open the browsed queues drop down and select a printer.
6. Print an ASCII text test page .
  

Actual Results:  The page from the second run is not identical to that of the first run. Some text is missing because it seems to have been printed "invisibly" outside of the margins of the page.

Expected Results:  Pages produced at 2. and 6. to be identical.

Additional info:
Comment 1 Tim Waugh 2005-03-07 12:46:52 EST
Looks like a duplicate of bug #115701.

*** This bug has been marked as a duplicate of 115701 ***
Comment 2 Tim Waugh 2005-04-26 07:54:48 EDT
This is indeed a separate issue, not to do with classes.
Comment 3 Tim Waugh 2005-05-16 13:39:16 EDT
I think the reason for this is that options in /etc/cups/lpoptions on the server
are not used by clients on a different machine -- and this seems to be intentional.

A related issue is that libgnomecups seems to ignore client lpoptions when
sending jobs to remote IPP queues.
Comment 4 Sitsofe Wheeler 2005-05-16 18:27:51 EDT
Agh.

Surely this hurts the usefulness of automatic queues if they actually have to be
configured?
Comment 5 Tim Waugh 2005-05-19 04:20:09 EDT
Well, it's worse than that actually -- system-config-printer won't let you
configure lpoptions for browsed queues. :-/
Comment 6 Sitsofe Wheeler 2006-05-26 11:25:49 EDT
This is still here in FC5. Can this be set against the devel version?
Comment 7 Tim Waugh 2006-05-26 11:50:47 EDT
I'm actually going to close this against the devel version, since network
default options are implemented in CUPS 1.2 and can be set using the
system-config-printer tool in Fedora Core devel.

Note You need to log in before you can comment on or make changes to this bug.