Bug 1504005 - Cluster can be created with empty 'Default network provided', which is causing NPE during host deploy
Summary: Cluster can be created with empty 'Default network provided', which is causin...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.0
: ---
Assignee: Allon Mureinik
QA Contact: Mor
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-19 09:37 UTC by Martin Perina
Modified: 2017-12-20 10:45 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-20 10:45:16 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
engine logs (315.72 KB, application/x-gzip)
2017-10-19 09:37 UTC, Martin Perina
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 82989 master MERGED core: Fix NPE in host deploy 2017-10-19 15:31:01 UTC

Description Martin Perina 2017-10-19 09:37:17 UTC
Created attachment 1340650 [details]
engine logs

Description of problem:

Cluster can be created with empty 'Default network provided', which is causing host deploy process to fail with 'Failed to configure management network on the host' and NPE is shown in the logs.

The cause of that is most probably that 'Default network provided' combo box is empty, so no value can be set into it

Version-Release number of selected component (if applicable):

master, Change-Id: I4b5338e4faa5e5dd36872a4772f86dca809a37bb

How reproducible:

100%

Steps to Reproduce:
1. Create a new cluster using webadmin (no value can be set in 'Default network provided' combo box)
2. Try to add a host into that cluster
3.

Actual results:

Cluster can be created with no value in 'Default network provided', which causes host deploy to fail

Expected results:

Cluster cannot be created without 'Default network provided' value

Additional info:

Comment 1 Martin Perina 2017-10-19 12:15:49 UTC
[1] is the patch is causing that issue, with engine before that change everything works fine.

[1] https://gerrit.ovirt.org/#/c/82545/

Comment 2 Mor 2017-10-30 14:29:57 UTC
Verified on:
4.2.0-0.0.master.20171027213842.gitded437c.el7.centos

Comment 3 Sandro Bonazzola 2017-12-20 10:45:16 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.