Bug 1504142 - [RFE] Packaging and containerization of openstack-kuryr-kubernetes in the Red Hat catalog
Summary: [RFE] Packaging and containerization of openstack-kuryr-kubernetes in the Red...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-kuryr-kubernetes
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Antoni Segura Puimedon
QA Contact: Jon Uriarte
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-19 14:30 UTC by Antoni Segura Puimedon
Modified: 2018-06-27 13:38 UTC (History)
7 users (show)

Fixed In Version: python-kuryr-lib-0.7.1-0.20171117165805.d8e39cd.el7ost openstack-kuryr-kubernetes-0.2.1-0.20171204102404.1aebde0.el7ost python-kuryr-tests-tempest-0.1.1-0.20171221092727.f8d436c.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:37:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 530927 None master: MERGED releases: Release kuryr-kubernetes 0.3 (Iac2fc0002e71430e0b9b6701e8ad069fcfa1e482) 2018-04-04 12:40:51 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:42 UTC

Description Antoni Segura Puimedon 2017-10-19 14:30:50 UTC
Description of problem:
openstack-kuryr-kubernetes is only packaged in RDO. We need it to be packages as part of Red Hat OpenStack Platform in order for it to be possible to build the containers from released products which is part of the inclusion criteria for Container images in the Red Hat catalog

Comment 7 Jon Schlueter 2018-01-03 20:25:54 UTC
looks like we need python-kubernetes as a runtime Requires for

*** package: python2-kuryr-tests-tempest-0.1.1-0.20171221092727.f8d436c.el7ost.noarch

is this anticipated and reasonable?

Comment 8 Antoni Segura Puimedon 2018-01-07 23:50:09 UTC
IIRC we only use that for scenario tests. I'll verify in the morning

Comment 10 Jon Schlueter 2018-01-18 10:44:11 UTC
moving back to post until we get containers built

Comment 11 Antoni Segura Puimedon 2018-02-14 11:46:11 UTC
In inventory/group_vars/all.yaml

Set:

    openshift_openstack_kuryr_controller_image: kuryr/controller:latest
    openshift_openstack_kuryr_cni_image: kuryr/cni:latest

To the RH catalog image locations

Comment 16 Jon Uriarte 2018-05-04 11:44:51 UTC
Verified with these kuryr images:
 https://access.redhat.com/containers/#/registry.access.redhat.com/rhosp13/openstack-kuryr-controller/images/13.0-38
 https://access.redhat.com/containers/#/registry.access.redhat.com/rhosp13/openstack-kuryr-cni/images/13.0-41

from 20180502.1 puddle

which have been taken from:
 docker-registry.engineering.redhat.com/rhosp13/openstack-kuryr-controller:latest
 docker-registry.engineering.redhat.com/rhosp13/openstack-kuryr-cni:latest

The version of kuryr-kubernetes components on those images are:

For controller:
 python2-kuryr-lib-0.7.0-1.el7ost.noarch
 openstack-kuryr-kubernetes-common-0.4.3-1.el7ost.noarch
 python2-kuryr-kubernetes-0.4.3-1.el7ost.noarch
 openstack-kuryr-kubernetes-controller-0.4.3-1.el7ost.noarch

For CNI:
 python2-kuryr-lib-0.7.0-1.el7ost.noarch
 openstack-kuryr-kubernetes-common-0.4.3-1.el7ost.noarch
 python2-kuryr-kubernetes-0.4.3-1.el7ost.noarch
 openstack-kuryr-kubernetes-cni-0.4.3-1.el7ost.noarch

Comment 18 errata-xmlrpc 2018-06-27 13:37:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.