Bug 1504208 - Monitor NULL bug XFCE4.12.0 when display port is unplugged or powers down
Summary: Monitor NULL bug XFCE4.12.0 when display port is unplugged or powers down
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: xfce4-settings
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-19 17:23 UTC by James Pulver
Modified: 2017-11-14 05:08 UTC (History)
2 users (show)

Fixed In Version: xfce4-settings-4.12.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-14 05:08:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Xfce 11107 None None None 2017-10-19 17:23:27 UTC

Description James Pulver 2017-10-19 17:23:28 UTC
Description of problem:
https://bugzilla.xfce.org/show_bug.cgi?id=11107

This problem seems to be present in EL7.4 (Scientific Linux 7.4) running xfce4-settings-4.12.0-7.

Version-Release number of selected component (if applicable):
4.12.0-7

How reproducible:
Install EL7.4 and XFCE4 group on computer with display port used for the monitor. I have tested on Lenovo P510 (nVidia) and Lenovo M700 (Intel graphics)

Steps to Reproduce:
1. Log in to XFCE.
2. Unplug or power down monitor
3. Turn monitor back on / power on monitor.

Actual results:
Blank screen - no signal. Can access virtual terminal via ctrl-alt-F2. 

Expected results:
Your XFCE session comes back.

Additional info:
Potential XFCE bug fix linked here:
https://git.xfce.org/xfce/xfce4-settings/commit/?id=2233f20a7ec6d7cb7dcc5752d62d98e37d9c21ad

Seems like building 4.13.1 or 4.12.1(if you didn't want 4.13) would include the linked patch.

Comment 1 Mukundan Ragavan 2017-10-19 17:35:20 UTC
I will update to 4.12.1 today and include other packages.

Comment 2 Fedora Update System 2017-10-25 02:13:21 UTC
xfce4-panel-4.12.1-4.el7 xfdesktop-4.12.4-3.el7 xfce4-settings-4.12.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-15fec5ecae

Comment 3 Fedora Update System 2017-10-26 14:08:30 UTC
xfce4-panel-4.12.1-4.el7, xfce4-settings-4.12.1-1.el7, xfdesktop-4.12.4-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-15fec5ecae

Comment 4 Fedora Update System 2017-11-14 05:08:10 UTC
xfce4-panel-4.12.1-4.el7, xfce4-settings-4.12.1-1.el7, xfdesktop-4.12.4-3.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.