Bug 1504301 - RHSM proxy can be down, users will never now
Summary: RHSM proxy can be down, users will never now
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: All
OS: All
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Emilien Macchi
QA Contact: Gurenko Alex
URL:
Whiteboard:
: 1505357 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-19 21:47 UTC by Emilien Macchi
Modified: 2018-06-27 13:38 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20171206151028.97e841d.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:37:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1724970 None None None 2017-10-19 21:47:46 UTC
OpenStack gerrit 513530 None None None 2017-10-19 21:50:35 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:42 UTC

Description Emilien Macchi 2017-10-19 21:47:46 UTC
Description of problem:

When using rhel_reg_http_proxy_* parameters for RHEL subscription, TripleO will never check if the proxy is actually available. If it's not, it will fail and the poor user will never know why (it will probably timeout).


Version-Release number of selected component (if applicable):
8, 9, 10, 11, 12.

How reproducible:
You need a RHSM proxy not available over the network (can be tested with a fake IP).

Actual results:
1. Deploy Director with RHSM environment and proxy parameters, with an IP that isn't reachable.
2. Deployment will fail after a timeout when trying to subscribe nodes.

Expected results:
1. Deploy Director with RHSM environment and proxy parameters, with an IP that isn't reachable.
2. Deployment should fail to subscribe nodes, since proxy isn't reachable.
3. A message should explain to the user that the proxy isn't available over the network.



Additional info:
The RHSM proxy feature was introduced in OSP12:
https://bugzilla.redhat.com/show_bug.cgi?id=1314480

Comment 1 James Slagle 2017-10-23 14:51:52 UTC
*** Bug 1505357 has been marked as a duplicate of this bug. ***

Comment 2 James Slagle 2017-10-23 14:52:40 UTC
I've marked https://bugzilla.redhat.com/show_bug.cgi?id=1505357 a duplicate of this bz. Should we consider backporting your fix to pike/12?

Comment 8 Gurenko Alex 2018-05-03 06:07:52 UTC
Verified on puddle 2018-05-01.6. Deployment fails with respective message that IP is not reachable.

Comment 10 errata-xmlrpc 2018-06-27 13:37:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.