Bug 150434 - http_proxy weirdness
http_proxy weirdness
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cvs (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-06 09:17 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 09:06:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ethereal dump of failed "cvs update" (1.35 KB, text/plain)
2005-03-06 09:17 EST, Ville Skyttä
no flags Details

  None (edit)
Description Ville Skyttä 2005-03-06 09:17:09 EST
The proxy patch applied in 1.11.19-3 causes weird breakage here; this is a FC3
system with cvs locally rebuilt and updated from FC devel CVS.

I have a local squid running, and http_proxy set to http://localhost:3128 in the
environment.  Now, all my cvs operations that use anonymous pserver fail with
messages like:

cvs [update aborted]: proxy server localhost:3128 does not support http tunnelling

Huh?  Why is it trying to use a HTTP proxy in the first place?  I requested a
CVS pserver operation, not HTTP traffic.  The error message is confusing as
squid most certainly supports HTTP proxying, and it works fine here using wget,
curl, $younameit.

Ethereal dump attached, and squid logs say:
==> /var/log/squid/access.log <==
1110118551.721      0 127.0.0.1 TCP_DENIED/403 1336 CONNECT cvs.cvshome.org:2401
- NONE/- text/html

==> /var/log/squid/store.log <==
1110118551.721 RELEASE -1 FFFFFFFF 652777049644E74A1CCE533ABF123F48  403
1110118551         0 1110118551 text/html 1044/1276 CONNECT cvs.cvshome.org:2401


I suggest turning this feature off by default, as it seems to be implemented in
a way that causes backwards incompatibility and breakage.  The changelog refers
to #144297 which I'm unable to access.
Comment 1 Ville Skyttä 2005-03-06 09:17:09 EST
Created attachment 111713 [details]
Ethereal dump of failed "cvs update"
Comment 2 Martin Stransky 2005-03-07 04:58:25 EST
Could you join please list of your env variables? Do you have set
"HTTP_PROXY", right?
Comment 3 Martin Stransky 2005-03-07 09:06:28 EST
I removed check of HTTP_PROXY. Now it works only with CVS_PROXY.
Comment 4 Ville Skyttä 2005-03-07 12:54:04 EST
That sounds like a good idea to me, thanks.  1.11.19-4 looks ok.

FWIW, here are my related environment variables:
$ env | grep -i proxy
http_proxy=http://localhost:3128
ftp_proxy=http://localhost:3128
no_proxy=localhost,bobcat.mine.nu,127.0.0.1

Note You need to log in before you can comment on or make changes to this bug.