Bug 150442 - lvm2 package obsoletes lvm < 1.0.3-19
lvm2 package obsoletes lvm < 1.0.3-19
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
Depends On:
  Show dependency treegraph
Reported: 2005-03-06 12:23 EST by Seth Vidal
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-192
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-08 09:51:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2005-03-06 12:23:55 EST
Description of problem:
The lvm2 package in rhel4 obsoletes lvm < 1.0.3-19. But lvm that ships with
rhel3 is lvm 1.0.8. so that eventhough lvm2 owns some of the same files as lvm
it cannot obsolete lvm.

All that's really needed is an update to this version string and/or to turn the
flag around so it is > rather than <.
Comment 1 Alasdair Kergon 2005-03-08 09:51:36 EST
The lvm package was changed in Fedora 1.0.3-19 so it could co-exist with lvm2 to 
assist people switching between 2.4 and 2.6 kernels.  Subsequently that change
was taken out of the lvm package but it seems the headers in the lvm2 spec file
were not updated to reflect that.

I've removed the condition now the two aren't allowed to co-exist.
Comment 2 Tim Powers 2005-06-09 08:30:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.