Bug 150456 - evince crashes opening ISO C++ Standard pdf file
evince crashes opening ISO C++ Standard pdf file
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marco Pesenti Gritti
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 00:04 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-08 09:31:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-03-07 00:04:32 EST
pdf_document_gets_link() at pdf-document:881 is passed a links_iter
whose first OutlineItem has a NULL action field.  So, when it calls
build_link_from_action, passing it the NULL link_action,
build_link_from_action crashes, since first thing it does is 
dereferencing it.

Version-Release number of selected component (if applicable):
evince-0.1.5-2

How reproducible:
Always
Comment 2 Marco Pesenti Gritti 2005-03-07 04:09:58 EST
This is fixed in evince-0.1.6, will update the package as soon as I
get permission of adding the new poppler dependency.

Note You need to log in before you can comment on or make changes to this bug.