Bug 150468 - Hard link count is wrong for /proc
Summary: Hard link count is wrong for /proc
Status: CLOSED DUPLICATE of bug 162418
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-07 14:02 UTC by John Ellson
Modified: 2015-01-04 22:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 23:15:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Ellson 2005-03-07 14:02:20 UTC
Description of problem:
Find warns that: Hard link count is wrong for /proc

Version-Release number of selected component (if applicable):
findutils-4.2.18-2
kernel-2.6.11-1.1171_FC4

How reproducible:
100%

Steps to Reproduce:
1. find / -name no-such-file
2.
3.
  
Actual results:
find: WARNING: Hard link count is wrong for /proc: this may be a bug
in your filesystem driver.  Automatically turning on find's -noleaf
option.  Earlier results may have failed to include directories that
should have been searched.


Expected results:
No warnings.

Additional info:

Comment 1 Chris Ricker 2005-06-10 19:00:20 UTC
I get that warning on 2.6.11-1.1369_FC4.i686 with findutils-4.2.20-1

Comment 2 Dave Jones 2005-07-15 21:52:53 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 3 John Ellson 2005-07-16 00:27:50 UTC
Problem still exists on x86_64:


root@ontap:~#  uname -a
Linux ontap 2.6.12-1.1433_FC5 #1 SMP Thu Jul 14 18:26:46 EDT 2005 x86_64 x86_64
x86_64 GNU/Linux
root@ontap:~# find / -name no-such-file
find: WARNING: Hard link count is wrong for /proc: this may be a bug in your
filesystem driver.  Automatically turning on find's -noleaf option.  Earlier
results may have failed to include directories that should have been searched.



but seems to be fixed on i686:

root@froth:~# uname -a
Linux froth 2.6.12-1.1433_FC5 #1 Thu Jul 14 18:27:55 EDT 2005 i686 i686 i386
GNU/Linux
root@froth:~# find / -name no-such-file


Comment 4 Leslie Satenstein 2005-08-09 04:08:32 UTC
Still exists in 2.6.12.1.1398_fc4 
The amd / 386 version 

Comment 5 Jeff Bambrough 2005-08-20 05:52:24 UTC
This still exists in 2.6.12-1.1398_FC4smp as well:

2.6.12-1.1398_FC4smp #1 SMP Fri Jul 15 01:30:13 EDT 2005 i686 i686 i386 GNU/Linux


Comment 6 Leslie Satenstein 2005-08-20 21:13:57 UTC
K3B burps when it reaches certain entries in the /proc subdirectory listing. 
Using K3B, one can easily tell which entry is defective (invalid)

Comment 7 Need Real Name 2005-08-31 12:36:06 UTC
Doesn't WFM.

# uname -r
2.6.12-1.1398_FC4smp

# find /proc/ 1>/dev/null
find: WARNING: Hard link count is wrong for /proc/: this may be a bug in your
filesystem driver.  Automatically turning on find's -noleaf option.  Earlier
results may have failed to include directories that should have been searched.


Comment 8 Dave Jones 2005-08-31 23:15:24 UTC

*** This bug has been marked as a duplicate of 162418 ***

Comment 9 Leslie Satenstein 2005-09-01 01:42:04 UTC
Still there with kernel-2.6.12-1.1447_FC4


Note You need to log in before you can comment on or make changes to this bug.