Bug 1504702 - cluster import failed
Summary: cluster import failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-commons
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Shubhendu Tripathi
QA Contact: Bala Konda Reddy M
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-20 12:35 UTC by Martin Kudlej
Modified: 2017-12-18 04:39 UTC (History)
6 users (show)

Fixed In Version: tendrl-commons-1.5.4-1.el7rhgs.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github Tendrl node-agent issues 627 None None None 2017-10-24 11:53:09 UTC

Description Martin Kudlej 2017-10-20 12:35:12 UTC
Description of problem:
It seems that there is missing conf file. This conf file is not present in tendrl-gluster-integration-1.5.3-2.el7rhgs or tendrl-commons-1.5.3-1.el7rhgs

error Failure in Job 38e9b0b3-a042-4181-a682-fea1d7181e3a Flow tendrl.flows.ImportCluster with error: Traceback (most recent call last): File "/usr/lib/python2.7/site-packages/tendrl/commons/jobs/__init__.py", line 218, in process_job the_flow.run() File "/usr/lib/python2.7/site-packages/tendrl/commons/flows/import_cluster/__init__.py", line 84, in run raise ex IOError: [Errno 2] No such file or directory: '/etc/tendrl/gluster-integration/gluster-integration_logging.yaml'


info Generating configuration for tendrl-gluster-integration on Node da23c369-fcef-4c7f-b63c-207b5471e071
info Released lock (614e7f8d-7415-4f4d-a6f7-4d2079036580) for Node (6c6efc2e-154e-4036-9f1d-e995e28c0433)
info Running tendrl-gluster-integration on Node 6c6efc2e-154e-4036-9f1d-e995e28c0433
info Generating configuration for tendrl-gluster-integration on Node 6c6efc2e-154e-4036-9f1d-e995e28c0433
info Waiting for participant nodes [u'da23c369-fcef-4c7f-b63c-207b5471e071', u'eab44a80-2bc5-42ff-aacc-13f82020788f', u'0665b6f6-305b-4004-8858-dba777f32cb1', u'748d0ca2-6d73-4f09-9c2c-2fbfa36b1297', u'6c6efc2e-154e-4036-9f1d-e995e28c0433', u'4f30d346-9e59-422b-81c3-dca67deb3cb4'] to be imported 38eb9442-f049-4633-8d9b-e6af32d5fd47
info Running tendrl-gluster-integration on Node eab44a80-2bc5-42ff-aacc-13f82020788f
info Generating configuration for tendrl-gluster-integration on Node eab44a80-2bc5-42ff-aacc-13f82020788f
info Installing tendrl-gluster-integration on Node 4f30d346-9e59-422b-81c3-dca67deb3cb4
info Check: Minimum required version (3.3.1) of Gluster Storage
info Installing tendrl-gluster-integration on Node 6c6efc2e-154e-4036-9f1d-e995e28c0433
info Check: Minimum required version (3.3.1) of Gluster Storage
info Acquired lock (d5449f82-bee5-4440-864c-f6c8d49539ad) for Node (4f30d346-9e59-422b-81c3-dca67deb3cb4)
info Installing tendrl-gluster-integration on Node 748d0ca2-6d73-4f09-9c2c-2fbfa36b1297
info Acquired lock (614e7f8d-7415-4f4d-a6f7-4d2079036580) for Node (6c6efc2e-154e-4036-9f1d-e995e28c0433)
info Check: Minimum required version (3.3.1) of Gluster Storage
info Acquired lock (b2a71bf6-d20a-4609-99ab-aca9bee5a80e) for Node (748d0ca2-6d73-4f09-9c2c-2fbfa36b1297)
info Running Flow tendrl.flows.ImportCluster
info Running Flow tendrl.flows.ImportCluster
info Processing Job d5449f82-bee5-4440-864c-f6c8d49539ad
info Processing Job 614e7f8d-7415-4f4d-a6f7-4d2079036580
info Running Flow tendrl.flows.ImportCluster
info Processing Job b2a71bf6-d20a-4609-99ab-aca9bee5a80e
info Installing tendrl-gluster-integration on Node 0665b6f6-305b-4004-8858-dba777f32cb1
info Check: Minimum required version (3.3.1) of Gluster Storage
info Acquired lock (75ae4d60-3e55-4458-9a64-6e5d72cab172) for Node (0665b6f6-305b-4004-8858-dba777f32cb1)
info Installing tendrl-gluster-integration on Node eab44a80-2bc5-42ff-aacc-13f82020788f
info Check: Minimum required version (3.3.1) of Gluster Storage
info Running Flow tendrl.flows.ImportCluster
info Importing (job: d5449f82-bee5-4440-864c-f6c8d49539ad) Node 4f30d346-9e59-422b-81c3-dca67deb3cb4 to cluster 38eb9442-f049-4633-8d9b-e6af32d5fd47
info Processing Job 75ae4d60-3e55-4458-9a64-6e5d72cab172
info Importing (job: 614e7f8d-7415-4f4d-a6f7-4d2079036580) Node 6c6efc2e-154e-4036-9f1d-e995e28c0433 to cluster 38eb9442-f049-4633-8d9b-e6af32d5fd47
info Importing (job: b2a71bf6-d20a-4609-99ab-aca9bee5a80e) Node 748d0ca2-6d73-4f09-9c2c-2fbfa36b1297 to cluster 38eb9442-f049-4633-8d9b-e6af32d5fd47
info Installing tendrl-gluster-integration on Node da23c369-fcef-4c7f-b63c-207b5471e071
info Check: Minimum required version (3.3.1) of Gluster Storage
info Importing (job: 75ae4d60-3e55-4458-9a64-6e5d72cab172) Node 0665b6f6-305b-4004-8858-dba777f32cb1 to cluster 38eb9442-f049-4633-8d9b-e6af32d5fd47
info Running Flow tendrl.flows.ImportCluster
info Processing Job 38e9b0b3-a042-4181-a682-fea1d7181e3a
info Importing (job: 38e9b0b3-a042-4181-a682-fea1d7181e3a) Node da23c369-fcef-4c7f-b63c-207b5471e071 to cluster 38eb9442-f049-4633-8d9b-e6af32d5fd47
info Acquired lock (4b880614-ed65-43e1-9113-a101c67b6b5e) for Node (da23c369-fcef-4c7f-b63c-207b5471e071)
info Running Flow tendrl.flows.ImportCluster
info Processing Job 4b880614-ed65-43e1-9113-a101c67b6b5e

Version-Release number of selected component (if applicable):
etcd-3.2.7-1.el7.x86_64
glusterfs-3.8.4-48.el7rhgs.x86_64
glusterfs-api-3.8.4-48.el7rhgs.x86_64
glusterfs-cli-3.8.4-48.el7rhgs.x86_64
glusterfs-client-xlators-3.8.4-48.el7rhgs.x86_64
glusterfs-events-3.8.4-48.el7rhgs.x86_64
glusterfs-fuse-3.8.4-48.el7rhgs.x86_64
glusterfs-geo-replication-3.8.4-48.el7rhgs.x86_64
glusterfs-libs-3.8.4-48.el7rhgs.x86_64
glusterfs-server-3.8.4-48.el7rhgs.x86_64
python-etcd-0.4.5-1.noarch
rubygem-etcd-0.3.0-1.el7.noarch
tendrl-ansible-1.5.3-2.el7rhgs.noarch
tendrl-api-1.5.3-2.el7rhgs.noarch
tendrl-api-httpd-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.3-1.el7rhgs.noarch
tendrl-gluster-integration-1.5.3-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.3-2.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.3-3.el7rhgs.noarch
tendrl-notifier-1.5.3-1.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-ui-1.5.3-2.el7rhgs.noarch


How reproducible:
hard to say, I see this for first time

Steps to Reproduce:
1. install gluster cluster with one disperse volume and tendrl
2. import cluster

Actual results:
Import failed.

Expected results:
Import should pass.

Comment 1 Daniel Horák 2017-10-23 13:54:21 UTC
I probably found the root cause of this issue. I've dig into same problem toady and I've discovered it as problem with installation of tendrl-gluster-integration package. There might be lot's of possible causes of that - improperly configured repositories, network issue, another package dependency issue,...

So the main problem probably is in the very unclear error message - it should fail immediately when installation of some package (for example tendrl-gluster-integration) fails and it should properly state the root cause of the issue (for example log output from yum install command).

Steps to Reproduce:
1. Prepare Tendrl server and Gluster cluster to be imported to Tendrl.
2. On one of the storage nodes disable tendrl repo (or rhel-7-server-extras-rpms repo) or perform some other action which will break the installation of tendrl-gluster-integration (for example add this package or some dependency as exclude=<package>  to /etc/yum.conf).
3. Try to Import the Gluster cluster into Tendrl.

Actual results:
  Import fails (which is expected), but the error message is not useful for debugging, there is no information about problem with package installation.

Expected results:
  Failed task should properly describe the root cause of the issue: problem with package installation.

Comment 2 Martin Bukatovic 2017-10-24 11:53:09 UTC
This has been reported in upstream on Sep 20 2017 with details to reproduce the issue, see: https://github.com/Tendrl/node-agent/issues/627

Wit this in mind, I would update the following sections of this report:

How reproducible: 100%
Steps to Reproduce: see the upstream issue linked above
Expected results: Tendrl should report an error about the fact that installation of the package failed, with details indicating why is that (based on yum error) if possible.

Comment 3 Martin Bukatovic 2017-10-24 11:57:56 UTC
Also note that the original upstream report contains the error message, so that one could find it via github issue search, eg.:

https://github.com/issues?utf8=%E2%9C%93&q=is%3Aissue+user%3ATendrl+No+such+file+or+directory%3A+%27%2Fetc%2Ftendrl%2Fgluster-integration%2Fgluster-integration_logging.yaml%27

Comment 4 Nishanth Thomas 2017-11-07 06:39:07 UTC
The linked upstream issue closed, hence moving the bug modified

Comment 10 errata-xmlrpc 2017-12-18 04:39:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.