Bug 150481 - Stopping of filesystem service fails with certain devices
Stopping of filesystem service fails with certain devices
Status: CLOSED RAWHIDE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 10:41 EST by Derek Anderson
Modified: 2009-04-16 16:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-06 16:45:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2005-03-07 10:41:56 EST
Description of problem:
Thanks to Ion Alberdi <ialberdi@histor.fr> for pointing this out.

The umount command does not work with all device types, as it is being
deprecated, according to the umount man page.  So if you are using,
for example, CLVMD block devices and one of these is used in an fs
service, that service will fail to stop.

The reason the service fails to stop is umount won't work with this
type of device:

[root@link-11 cluster]# mount | grep VG3
/dev/VG3/LV3 on /mnt/gfs3 type ext3 (rw)
[root@link-11 cluster]# umount /dev/VG3/LV3
umount: /dev/VG3/LV3: not mounted
[root@link-11 cluster]# umount /mnt/gfs3
[root@link-11 cluster]#

By changing line 821 of /usr/share/cluster/fs.sh from:
umount $dev
to
umount $mp

The service will now stop properly.  Haven't scoured the script yet,
so there may well be other places that need to be changed.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lon Hohberger 2005-03-07 11:05:36 EST
Ah, an artifact of 5-year-old mount/umount code ;)
Comment 2 Lon Hohberger 2005-03-07 11:06:21 EST
Er, why will 'mount' work but not 'umount' ?
Comment 3 Lon Hohberger 2005-03-07 12:22:43 EST
Fixed in CVS
Comment 4 Lon Hohberger 2005-03-07 12:44:06 EST
Needs to follow symlinks in status portion so that we can compare
multiple possible outputs of mount(1).

(Don't forget to watch for symlink loops.)

e.g.:

fstab has: 
   /dev/vg0/root

which is a symlink to:
   /dev/mapper/vg0-root

The latter is what mount(1) reports.

Comment 5 Lon Hohberger 2005-03-07 12:57:57 EST
Derek noted that we should run down symlinks in the output of mount too.
Comment 6 Lon Hohberger 2005-03-07 14:53:16 EST
Fixes in CVS.

a. Walks symlinks / does findfs / whatever for specifed device
b. Figures out if mount output is a symlink and traces it for each
"device" output from mount(1).

fs.sh should work with symlinks specified, UUID=<foo>, LABEL=<foo>,
and directly-specified devices (e.g. /dev/sda1) now, even if the
output of mount(1) doesn't directly match what was specified in
cluster.conf (as long as the final device matches...).
Comment 7 Lon Hohberger 2005-05-06 16:45:36 EDT
These have been fixed in CVS for some time; closing

Note You need to log in before you can comment on or make changes to this bug.