Bug 150484 - iscsi initiator fails to logout
iscsi initiator fails to logout
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iscsi-initiator-utils (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 10:54 EST by Bill Peck
Modified: 2008-04-07 00:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-26 13:15:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2005-03-07 10:54:17 EST
Description of problem:
Our initiator fails to logout at the end of our session.

2.4.21-28.ELsmp
Comment 1 Mike Christie 2005-06-09 15:39:05 EDT
Does fail to logout mean send a logout PDU? We do not send a logout on the 4.0
version. I think it actually does on the 3.X version in certain cases though.
Why do you need this? It is not required.
Comment 2 Tom Coughlan 2005-06-24 18:07:22 EDT
This was a result of connectathon. Bill, any background on why someone thought
it was important?
Comment 3 Bill Peck 2005-06-25 09:54:49 EDT
EMC is who originally brought it up at Connectathon.

I then talked about it with NetApp and I'm trying to remember what they said. 
They confirmed we didn't log out but said it didn't much matter to them at the
moment.  But Some new error handling ability in the future could be affected by
this?  I'll look through my notes on Monday and see if I wrote it down.

Oh right.. I think I remember.. in the future, You will have to log out, just
dissapearing won't log you out since they will keep the connection open for
error recovery.  I think the concern was that we might exhaust resources on the
iSCSI target?
Comment 4 Tom Coughlan 2005-09-25 20:47:38 EDT
My inclination on this is to keep it in mind for RHEL 5, and maybe also address
it in RHEL 4 if the risk and effort are low. I would not change RHEL 3 at this
point unless we get a customer complaint. 

Mike, I'll assign it to you. Maybe take a look at open-iscsi and RHEL 4 to see
if we can be better citizens by logging out when there is a controlled end of
session event. You can close this BZ, or assign it to RHEL 4 or 5. 
Comment 5 Mike Christie 2005-09-26 13:15:25 EDT
I am closing this BZ. It is not a bug. The RFC is not going to change anytime
soon becuase the behavior is needed for things like erl=0. For open-iscsi we are
going to do it when we get time. For RHEL3 we can log out sometimes, but that
code actually has a bug which no body has seemed to notice (I just happened to
find it when I was cleaniing up the RHEL4 codde :)). For RHEL4, we actually had
it but took it out due to some werird interop/RFC interpretation problem or worries.

Note You need to log in before you can comment on or make changes to this bug.