Bug 150486 - %pre/%post scriptlets fail during yum cron
%pre/%post scriptlets fail during yum cron
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-07 11:27 EST by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 15:27:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2005-03-07 11:27:07 EST
Description of problem:

System is kept up to date with the yum daily cron.  When updating packages, the
%pre and %post scriptlets fail:

/etc/cron.daily/yum.cron:

error: %pre(kernel-smp-2.6.10-1.770_FC3.i686) scriptlet failed, exit status 255
error:   install: %pre scriptlet failed (2), skipping kernel-smp-2.6.10-1.770_FC3

I believe the corresponding audit error is:

type=KERNEL msg=audit(1110195203.062:9853596): item=0 name=/bin/sh inode=28707
dev=00:00
type=KERNEL msg=audit(1110195203.062:9853596): avc:  denied  { transition } for
 pid=20780 exe=/usr/bin/python path=/bin/bash dev=dm-1 ino=28707
scontext=system_u:system_r:crond_t tcontext=system_u:system_r:unconfined_t
tclass=process


Version-Release number of selected component (if applicable):

selinux-policy-targeted-1.21.15-3

How reproducible:
Every time
Comment 1 Daniel Walsh 2005-03-08 11:24:27 EST
Added the transition rule selinux-policy-targeted-1.21.15-7

This should fix this error, there could be other access rules that are
not got, please try it out.

Dan
Comment 2 Orion Poplawski 2005-04-08 15:27:32 EDT
I have not seen this since the update.  I think we can consider it fixed.

Note You need to log in before you can comment on or make changes to this bug.