Bug 1504961 - [RFE] As a basic deployer I want to select which Roles are going to be used for deployment
Summary: [RFE] As a basic deployer I want to select which Roles are going to be used f...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Jiri Tomasek
QA Contact: Udi
URL: https://blueprints.launchpad.net/trip...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-20 20:01 UTC by Anandeep Pannu
Modified: 2018-06-27 13:38 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-ui-8.2.1-0.20180227100337.517cd78.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:37:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 512266 None master: MERGED tripleo-ui: Select Roles feature (I1f30c46fa78b05a4dd06d657596327e680add608) 2018-02-28 13:41:10 UTC
OpenStack gerrit 521510 None master: MERGED tripleo-ui: Submit select roles (I1305b5cb1522ca18f03c4c5113b822a86aff5d97) 2018-02-28 13:41:03 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:38:42 UTC

Description Anandeep Pannu 2017-10-20 20:01:42 UTC
Description of problem:
This RFE is to be more granular about composable roles. This feature focuses on the selection of the roles that are going to be used for deployment

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Jiri Tomasek 2017-11-13 10:08:48 UTC
Here is the upstream Launchpad umbrella blueprint https://blueprints.launchpad.net/tripleo/+spec/roles-management

Comment 5 Julie Pichon 2017-12-13 15:10:08 UTC
Adjusting status.

Here are the UI patches which implement the functionality:
https://review.openstack.org/#/c/512266/
https://review.openstack.org/#/c/512265/
https://review.openstack.org/#/c/509415/
https://review.openstack.org/#/c/512266/

The patches depend on the backend functionality in tripleo-common merging. The patches for that have been given the go ahead upstream for merging in Queens (upstream meeting Dec 12).

https://review.openstack.org/#/c/508514/
https://review.openstack.org/#/c/509832/
and I think https://review.openstack.org/#/c/508567/

Comment 7 Jiri Tomasek 2018-01-11 14:03:14 UTC
Current status:
4 Pending tripleo-common patches: https://review.openstack.org/#/c/528282
2 Pending tripleo-ui patches: https://review.openstack.org/521510

Comment 10 Jiri Tomasek 2018-01-24 13:56:53 UTC
4 Pending tripleo-common patches:
https://review.openstack.org/#/c/508567/ +2+2+1 waits for CI gate to pass to merge
https://review.openstack.org/#/c/509832/ +2+2+1 waits for ^ to merge
https://review.openstack.org/#/c/515045/ +2 needs to pass CI
https://review.openstack.org/#/c/528282/ +2+1 needs +2 (passes CI)

2 Pending depending tripleo-ui-patches:
  https://review.openstack.org/#/c/512266/15 +2+2+1 passed gate, waits for ^ to merge
  https://review.openstack.org/#/c/521510/13 needs reviews, waiting for the previous one to merge

Comment 11 Jiri Tomasek 2018-01-29 15:33:38 UTC
3 Pending tripleo-common patches:
https://review.openstack.org/#/c/508567/ Merged
https://review.openstack.org/#/c/509832/ +2+2+1 needs CI to pass gate
https://review.openstack.org/#/c/515045/ +2 needs to pass CI
https://review.openstack.org/#/c/528282/ +2+1 needs +2 (passes CI)

2 Pending depending tripleo-ui-patches:
  https://review.openstack.org/#/c/512266/15 +2+2+1 passed gate, waits for ^ to merge
  https://review.openstack.org/#/c/521510/13 needs reviews, waiting for the previous one to merge

Comment 12 Jiri Tomasek 2018-01-30 07:00:45 UTC
2 Pending tripleo-common patches:
https://review.openstack.org/#/c/508567/ Merged
https://review.openstack.org/#/c/509832/ Merged
https://review.openstack.org/#/c/515045/ +2 needs +2 (passes CI)
https://review.openstack.org/#/c/528282/ +2 needs +2 (passes CI)

1 Pending depending tripleo-ui-patches:
  https://review.openstack.org/#/c/512266/15 Merged
  https://review.openstack.org/#/c/521510/13 needs reviews, waiting for remaining tripleo-common patches to merge

Comment 13 Jiri Tomasek 2018-01-31 11:46:08 UTC
All tripleo-common patches merged

1 Pending depending tripleo-ui-patches:
  https://review.openstack.org/#/c/512266/15 Merged
  https://review.openstack.org/#/c/521510/13 needs reviews, waiting for CI gate to get unblocked

Comment 14 Jiri Tomasek 2018-01-31 22:25:58 UTC
All patches are merged now

Comment 16 Udi 2018-04-18 05:30:19 UTC
Verified: openstack-tripleo-ui-8.3.1-2.el7ost.noarch
Only the GUI was tested, unfortunately deployments still fail due to templating issues.

Comment 18 errata-xmlrpc 2018-06-27 13:37:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.