Bug 1505149 - file associations completely broken on lxqt
Summary: file associations completely broken on lxqt
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xdg-utils
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-22 12:59 UTC by Karel Volný
Modified: 2018-03-13 23:12 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-13 23:12:23 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 103146 None None None 2017-10-22 18:10 UTC
Red Hat Bugzilla 1514543 None None None Never

Internal Trackers: 1514543

Description Karel Volný 2017-10-22 12:59:35 UTC
Description of problem:
After upgrading to Fedora 27, I'm no longer able to open files in their associated applications.

Version-Release number of selected component (if applicable):
xdg-utils-1.1.2-2.fc27.noarch

How reproducible:
always

Steps to Reproduce:
0. open configuration center, go to file associations, find pdf, verify that it is associated to qpdfview
1. click a link to file in a browser (I use qupzilla), choose to open
2. 'execute' the file in mc
3. xdg-open 201706261647573300.pdf
Actual results:
1. nothing visible happens
2. /usr/libexec/mc/ext.d/doc.sh: line 106: xpdf: command not found
3. /usr/bin/xdg-open: line 922: pcmanfm: command not found


Expected results:
the file is opened in qpdfview in all the cases


Additional info:
note that I use LXQt, if that matters

I'm using pdf as example but the problem is with all mimetypes

Comment 1 Rex Dieter 2017-10-22 13:05:42 UTC
Looks like xdg-open expects pcmanfm to be present on lxqt

Do you know what the default/preferred file manager is on lxqt these days?

Comment 2 Rex Dieter 2017-10-22 13:08:18 UTC
I guess while we're at it, can you post output from:

echo $XDG_CURRENT_DESKTOP 
and
echo $DESKTOP SESSION

Comment 3 Karel Volný 2017-10-23 09:11:15 UTC
(In reply to Rex Dieter from comment #1)
> Do you know what the default/preferred file manager is on lxqt these days?

not sure what is preferred, but I have pcmanfm-qt installed ...

however, while pcmanfm-qt is able to pass the file to qpdfview, I don't understand why the mimeinfo association is not used directly - pcmanfm-qt is not a hard dependency, uninstalling it would then lead to the same situation

(In reply to Rex Dieter from comment #2)
> echo $XDG_CURRENT_DESKTOP 
> and
> echo $DESKTOP SESSION

$ echo $XDG_CURRENT_DESKTOP
X-LXQt
$ echo $DESKTOP_SESSION
/usr/share/xsessions/lxqt

Comment 4 Raphael Groner 2018-02-11 10:37:45 UTC
Another sample of failing xdg-open is reproducibe within trojita. I tries a bunch of options for possible browsers but qupzilla is missing in that list.

Workaround: xdg-settings set default-web-browser org.qupzilla.QupZilla.desktop

Is the odd name for the desktop file intentional?

See https://bbs.archlinux.org/viewtopic.php?pid=1731557#p1731557

IMHO this bug should be tracked by the LXQt SIG.

Comment 5 Kevin Kofler 2018-02-11 11:27:48 UTC
Yes, the naming convention is intentional, blame AppStream for introducing it. (AppStream application names use that format, they recommend that the AppData file name matches the AppStream name, and the .desktop file name must match the AppData file name.)

QupZilla upstream changed from qupzilla.desktop to org.qupzilla.QupZilla.desktop in 2.2.

Comment 6 Fedora Update System 2018-02-27 22:14:15 UTC
xdg-utils-1.1.2-4.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-c585d8cf91

Comment 7 Fedora Update System 2018-02-28 18:09:31 UTC
xdg-utils-1.1.2-4.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-c585d8cf91

Comment 8 Fedora Update System 2018-03-13 23:12:23 UTC
xdg-utils-1.1.2-4.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.