Bug 150516 - no sound with built-in intel chipset with latest kernel (770)
no sound with built-in intel chipset with latest kernel (770)
Status: CLOSED DUPLICATE of bug 144742
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-03-07 16:58 EST by Brandon
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-07-30 16:16:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brandon 2005-03-07 16:58:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
After updating to kernel-2.6.10-1.770_FC3 onboard sound no longer
functions. When reverting to kernel-2.6.9-1.667 (the one that comes
with  FC3) sound behaves normally.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot kernel-2.6.10-1.770_FC3

Actual Results:  Sound no longer works.

Expected Results:  Sound should work.

Additional info:

In Gstreamer preferences when I try to test, I receive this error:
Failed to construct test pipeline for 'ALSA - Advanced Linux Sound

The soundcard detection script detects my soundcard, but fails to play
the test sound.

alsamixer reports that everything that should be unmuted, is.

Audio device is:
00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM
(ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
        Subsystem: IBM: Unknown device 0537
        Flags: bus master, medium devsel, latency 0, IRQ 11
        I/O ports at 1c00 [size=256]
        I/O ports at 18c0 [size=64]
        Memory at c0000c00 (32-bit, non-prefetchable) [size=512]
        Memory at c0000800 (32-bit, non-prefetchable) [size=256]
        Capabilities: [50] Power Management version 2

The system is an IBM Thinkpad T42, id 23795VU.
Comment 1 Brandon 2005-03-09 09:52:24 EST
I found out that issuing a suspend to RAM fixed the sound issue. Even after a reboot, the 
sound seems to work perfectly fine.
Comment 2 Dave Jones 2005-07-15 16:21:42 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Brandon 2005-07-20 10:21:51 EDT
I have updated to FC4 and the bug does not occur.

Comment 4 Warren Togami 2005-07-30 16:16:04 EDT

*** This bug has been marked as a duplicate of 144742 ***

Note You need to log in before you can comment on or make changes to this bug.