Bug 1505178 - mariadb/mariadb-connector-c conflicts
Summary: mariadb/mariadb-connector-c conflicts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-22 20:34 UTC by Truls Gulbrandsen
Modified: 2017-11-11 20:06 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-11 03:09:59 UTC


Attachments (Terms of Use)

Description Truls Gulbrandsen 2017-10-22 20:34:39 UTC
Description of problem:
Unable to install Digikam due to error in Mariadb

Version-Release number of selected component (if applicable):

digikam                  x86_64 5.7.0-2.fc27 

How reproducible:

Running install digikam
Running install mariadb

Steps to Reproduce:
1. dnf install digikam
2. dnf install mariadb
3.

Actual results:

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib64/mysql/plugin/dialog.so from install of mariadb-common-3:10.2.9-3.fc27.x86_64 conflicts with file from package mariadb-connector-c-3.0.2-11.fc27.x86_64
  file /usr/lib64/mysql/plugin/mysql_clear_password.so from install of mariadb-common-3:10.2.9-3.fc27.x86_64 conflicts with file from package mariadb-connector-c-3.0.2-11.fc27.x86_64
  file /usr/lib64/mysql/libmariadb.so.3 from install of mariadb-libs-3:10.2.9-3.fc27.x86_64 conflicts with file from package mariadb-connector-c-3.0.2-11.fc27.x86_64
  file /usr/lib64/mysql/plugin/auth_gssapi_client.so from install of mariadb-server-3:10.2.9-3.fc27.x86_64 conflicts with file from package mariadb-connector-c-3.0.2-11.fc27.x86_64
  file /usr/lib64/mysql/plugin/sha256_password.so from install of mariadb-server-3:10.2.9-3.fc27.x86_64 conflicts with file from package mariadb-connector-c-3.0.2-11.fc27.x86_64

Error Summary

Expected results:


Additional info:

Comment 1 Rex Dieter 2017-10-22 22:18:12 UTC
This is a bug in mariadb/mariadb-connector-c packaging

(probably a missing Conflicts somewhere)

That said, doing a
dnf update
first may help resolve this.

Comment 2 Michal Schorm 2017-10-23 12:11:13 UTC
Yes, this looks like an issue with mariadb packaging.

I'll look into it.

Comment 3 Jeremy Linton 2017-10-24 21:40:47 UTC
Same problem on f27/aarch64, but I hit it during an `dnf upgrade`.

Comment 4 Michal Schorm 2017-10-25 04:30:34 UTC
Btw as I look at it again ...

There is a big update in rawhide (f28): #1486480
However, that change is only applicable to Rawhide. If the packages applied the patch to f27 too, it will break the build, because in f27 it is expected for those two packages to conflict.

mariadb-connector-c is basicaly part of mariadb. It has the same library, header files, plugins ... and so on.
In Rawhide, that exact part of mariadb has been removed, and its functionality is fully provided by the connector.

That's why in f28 it works fine, while in f27 they are expected to conflict.

Comment 5 Truls Gulbrandsen 2017-10-25 17:07:21 UTC
(In reply to Rex Dieter from comment #1)
> This is a bug in mariadb/mariadb-connector-c packaging
> 
> (probably a missing Conflicts somewhere)
> 
> That said, doing a
> dnf update
> first may help resolve this.

I tested this before reporting the bug.:

-dnf upgrade
-dnf update
-dnf clean all

However to no avail.

Comment 6 Truls Gulbrandsen 2017-10-25 17:15:56 UTC
(In reply to Michal Schorm from comment #4)
> Btw as I look at it again ...
> 
> There is a big update in rawhide (f28): #1486480
> However, that change is only applicable to Rawhide. If the packages applied
> the patch to f27 too, it will break the build, because in f27 it is expected
> for those two packages to conflict.
> 
> mariadb-connector-c is basicaly part of mariadb. It has the same library,
> header files, plugins ... and so on.
> In Rawhide, that exact part of mariadb has been removed, and its
> functionality is fully provided by the connector.
> 
> That's why in f28 it works fine, while in f27 they are expected to conflict.


Should I then enable rawhide and install Digikam? Would I then incur other problems with my installation?

I have no vital data on this computer and could test it, but not if it certain that I will break the installation and be forced to make a complete re-installation.

Comment 7 Michal Schorm 2017-10-25 17:28:59 UTC
I don't expect any issues, if you would use the rawhide packages.
However, I will test it for you first.

The situation again:
 - you have f27
 - you DON'T have digikam
 - you DON'T have mariadb or mariadb-connector-c
 - you want to install digikam from f27 repository

Is that correct?

Comment 8 Truls Gulbrandsen 2017-10-25 18:47:32 UTC
(In reply to Michal Schorm from comment #7)
> I don't expect any issues, if you would use the rawhide packages.
> However, I will test it for you first.
> 
> The situation again:
>  - you have f27
>  - you DON'T have digikam
>  - you DON'T have mariadb or mariadb-connector-c
>  - you want to install digikam from f27 repository
> 
> Is that correct?

Yes, that is correct.

Comment 9 Michal Schorm 2017-10-26 14:51:02 UTC
Strange.
You, as a user, shouldn't meet mariadb-connector-c in F<=27 at all. It is present, but shouldn't be used.

I picked clean F26 machine, chnaged its repos configuration to F27 and updated. (~700 packages affected)
Then, I ordered 'digikam' installation. It picked mariadb (instead of mariadb-connector-c) as it should. Installed without any problem.



[root@test ~]# dnf list installed | grep mariadb
mariadb.x86_64                       3:10.2.9-3.fc27                    @fedora 
mariadb-common.x86_64                3:10.2.9-3.fc27                    @fedora 
mariadb-config.x86_64                3:10.2.9-3.fc27                    @fedora 
mariadb-errmsg.x86_64                3:10.2.9-3.fc27                    @fedora 
mariadb-libs.x86_64                  3:10.2.9-3.fc27                    @fedora 
mariadb-server.x86_64                3:10.2.9-3.fc27                    @fedora 
mariadb-server-utils.x86_64          3:10.2.9-3.fc27                    @fedora 
[root@test ~]# dnf list installed | grep digikam
digikam.x86_64                       5.7.0-2.fc27                       @fedora 
digikam-doc.noarch                   5.7.0-2.fc27                       @fedora 
digikam-libs.x86_64                  5.7.0-2.fc27                       @fedora

Comment 10 Truls Gulbrandsen 2017-10-26 17:49:39 UTC
(In reply to Michal Schorm from comment #9)
> Strange.
> You, as a user, shouldn't meet mariadb-connector-c in F<=27 at all. It is
> present, but shouldn't be used.
> 
> I picked clean F26 machine, chnaged its repos configuration to F27 and
> updated. (~700 packages affected)
> Then, I ordered 'digikam' installation. It picked mariadb (instead of
> mariadb-connector-c) as it should. Installed without any problem.
> 
> 
> 
> [root@test ~]# dnf list installed | grep mariadb
> mariadb.x86_64                       3:10.2.9-3.fc27                   
> @fedora 
> mariadb-common.x86_64                3:10.2.9-3.fc27                   
> @fedora 
> mariadb-config.x86_64                3:10.2.9-3.fc27                   
> @fedora 
> mariadb-errmsg.x86_64                3:10.2.9-3.fc27                   
> @fedora 
> mariadb-libs.x86_64                  3:10.2.9-3.fc27                   
> @fedora 
> mariadb-server.x86_64                3:10.2.9-3.fc27                   
> @fedora 
> mariadb-server-utils.x86_64          3:10.2.9-3.fc27                   
> @fedora 
> [root@test ~]# dnf list installed | grep digikam
> digikam.x86_64                       5.7.0-2.fc27                      
> @fedora 
> digikam-doc.noarch                   5.7.0-2.fc27                      
> @fedora 
> digikam-libs.x86_64                  5.7.0-2.fc27                      
> @fedora

I made a clean installation of Fedora Design Suite Live 27_B-1-5

I get the following response trying your commands:

[root@localhost ~]# dnf list installed | grep mariadb
mariadb-connector-c.x86_64             3.0.2-11.fc27            @updates-testing
[root@localhost ~]# 

[root@localhost ~]# dnf list installed | grep digikam
[root@localhost ~]# 
[root@localhost ~]# dnf remove mariadb*
Dependencies resolved.
================================================================================
 Package                 Arch     Version              Repository          Size
================================================================================
Removing:
 mariadb-connector-c     x86_64   3.0.2-11.fc27        @updates-testing   375 k
Removing dependent packages:
 OpenImageIO             x86_64   1.7.17-2.fc27        @updates-testing   9.3 M
 armadillo               x86_64   7.900.1-3.fc27       @anaconda           47 k
 blender                 x86_64   1:2.79-1.fc27        @updates-testing   143 M
 boost-locale            x86_64   1.64.0-3.fc27        @updates-testing   920 k
 gdal-libs               x86_64   2.1.4-5.fc27         @anaconda           19 M
 lapack                  x86_64   3.7.1-5.fc27         @anaconda           16 M
 libspatialite           x86_64   4.3.0a-6.fc27        @anaconda           11 M
 opencv-contrib          x86_64   3.2.0-12.fc27        @updates-testing   6.5 M
 opencv-core             x86_64   3.2.0-12.fc27        @updates-testing    12 M
 openvdb-libs            x86_64   4.0.2-1.fc27         @updates-testing   3.8 M
 tesseract               x86_64   3.05.01-3.fc27       @anaconda           40 M
Removing unused dependencies:
 Field3D                 x86_64   1.7.2-8.fc27         @anaconda          2.4 M
 SuperLU                 x86_64   5.2.0-4.fc27         @anaconda          492 k
 alembic-libs            x86_64   1.7.3-1.fc27         @updates-testing   2.1 M
 arpack                  x86_64   3.5.0-4.fc27         @anaconda          628 k
 blas                    x86_64   3.7.1-5.fc27         @anaconda          765 k
 blender-fonts           noarch   1:2.79-1.fc27        @updates-testing   4.9 M
 blosc                   x86_64   1.11.3-3.fc27        @anaconda          103 k
 boost-atomic            x86_64   1.64.0-3.fc27        @updates-testing   7.9 k
 boost-chrono            x86_64   1.64.0-3.fc27        @updates-testing    17 k
 boost-program-options   x86_64   1.64.0-3.fc27        @updates-testing   496 k
 boost-regex             x86_64   1.64.0-3.fc27        @updates-testing   1.0 M
 boost-thread            x86_64   1.64.0-3.fc27        @updates-testing   166 k
 cfitsio                 x86_64   3.370-10.fc27        @updates-testing   1.6 M
 freexl                  x86_64   1.0.4-1.fc27         @updates-testing    62 k
 geos                    x86_64   3.6.1-4.fc27         @anaconda          1.9 M
 jemalloc                x86_64   4.5.0-4.fc27         @anaconda          647 k
 leptonica               x86_64   1.74.4-3.fc27        @anaconda          2.6 M
 libdap                  x86_64   3.18.3-4.fc27        @anaconda          2.1 M
 libdc1394               x86_64   2.2.2-9.fc27         @anaconda          330 k
 libgeotiff              x86_64   1.4.0-11.fc27        @anaconda          5.4 M
 libgta                  x86_64   1.0.7-6.fc27         @anaconda           70 k
 libkml                  x86_64   1.3.0-8.fc27         @anaconda          1.3 M
 libspnav                x86_64   0.2.3-6.fc27         @anaconda           17 k
 libucil                 x86_64   0.9.10-15.fc27       @anaconda          190 k
 libunicap               x86_64   0.9.12-20.fc27       @anaconda          402 k
 minizip                 x86_64   1.2.11-4.fc27        @anaconda           50 k
 netcdf                  x86_64   4.4.1.1-6.fc27       @anaconda          2.4 M
 ogdi                    x86_64   3.2.0-3.fc27         @anaconda          906 k
 openblas-openmp         x86_64   0.2.20-3.fc27        @updates-testing    35 M
 openblas-threads        x86_64   0.2.20-3.fc27        @updates-testing    35 M
 openblas-threads64_     x86_64   0.2.20-3.fc27        @updates-testing    35 M
 openjpeg-libs           x86_64   1.5.1-19.fc27        @anaconda          165 k
 openni                  x86_64   1.5.7.10-11.fc27     @fedora            1.4 M
 postgresql-libs         x86_64   9.6.5-1.fc27         @updates-testing   723 k
 proj                    x86_64   4.9.3-4.fc27         @anaconda          583 k
 unixODBC                x86_64   2.3.4-7.fc27         @anaconda          1.2 M
 uriparser               x86_64   0.8.4-6.fc27         @anaconda          136 k
 xerces-c                x86_64   3.1.4-4.fc27         @anaconda          3.6 M

Transaction Summary
================================================================================
Remove  50 Packages

Freed space: 408 M
Is this ok [y/N]: ^COperation aborted.
[root@localhost ~]# 

As you see there might be great consequences removing mariadb-connector-c.x86_64 .

Maybe this can give you clue to the problem, and I apologize if I have misled you in not specifying the Fedora flavour. I didn't think about it until I saw your dnf-commands.

Comment 11 Michal Schorm 2017-10-30 13:03:41 UTC
I discussed your issue with colleagues. It went out, that your issue is probably much more serious than I thought.
The mariadb-connector-c package is present in f27, but should not be used.


To remove conflicts between mariadb and connector in Fedoras<=27, I decided to empty the connector package. That means, it won't provide any functionality, it will only pull in correct mariadb packages.

I would like you to test it, before I distribute the update.
https://koji.fedoraproject.org/koji/taskinfo?taskID=22807153

--

I made following test on my machine with F27:

* dnf install bleder
    (pulls in mariadb-connector-c-3.0.2-4)
* dnf update https://kojipkgs.fedoraproject.org//work/tasks/7154/22807154/mariadb-connector-c-3.0.2-13.fc27.x86_64.rpm
  (updates mariadb-connector-c to 3.0.2-13, pulls in mariadb-libs)
*dnf install digikam

Everything went alright, Blender and Digikam runs.

--

So I hope this will solve the issue for you.

Comment 12 Truls Gulbrandsen 2017-10-30 17:06:30 UTC
(In reply to Michal Schorm from comment #11)
> I discussed your issue with colleagues. It went out, that your issue is
> probably much more serious than I thought.
> The mariadb-connector-c package is present in f27, but should not be used.
> 
> 
> To remove conflicts between mariadb and connector in Fedoras<=27, I decided
> to empty the connector package. That means, it won't provide any
> functionality, it will only pull in correct mariadb packages.
> 
> I would like you to test it, before I distribute the update.
> https://koji.fedoraproject.org/koji/taskinfo?taskID=22807153
> 
> --
> 
> I made following test on my machine with F27:
> 
> * dnf install bleder
>     (pulls in mariadb-connector-c-3.0.2-4)
> * dnf update
> https://kojipkgs.fedoraproject.org//work/tasks/7154/22807154/mariadb-
> connector-c-3.0.2-13.fc27.x86_64.rpm
>   (updates mariadb-connector-c to 3.0.2-13, pulls in mariadb-libs)
> *dnf install digikam
> 
> Everything went alright, Blender and Digikam runs.
> 
> --
> 
> So I hope this will solve the issue for you.

Thank you, it all seems to work - except I haven't tested the MariaDB yet - but digikam with seems to be ok.

I did the following:

[root@localhost ~]# dnf update
Last metadata expiration check: 0:00:00 ago on ma. 30. okt. 2017 kl. 17.38 +0100.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost ~]# dnf upgrade
Last metadata expiration check: 0:00:07 ago on ma. 30. okt. 2017 kl. 17.38 +0100.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost ~]# dnf install blender
Last metadata expiration check: 0:01:48 ago on ma. 30. okt. 2017 kl. 17.38 +0100.
Package blender-1:2.79-1.fc27.x86_64 is already installed, skipping.
Dependencies resolved.
Nothing to do.
Complete!
[root@localhost ~]# dnf update https://kojipkgs.fedoraproject.org//work/tasks/7154/22807154/mariadb-connector-c-3.0.2-13.fc27.x86_64.rpm
Last metadata expiration check: 0:02:12 ago on ma. 30. okt. 2017 kl. 17.38 +0100.
mariadb-connector-c-3.0.2-13.fc27.x86_64.rpm    6.7 kB/s | 9.3 kB     00:01    
Dependencies resolved.
================================================================================
 Package                 Arch       Version              Repository        Size
================================================================================
Upgrading:
 mariadb-connector-c     x86_64     3.0.2-13.fc27        @commandline     9.3 k
Installing dependencies:
 mariadb-common          x86_64     3:10.2.9-3.fc27      fedora            61 k
 mariadb-config          x86_64     3:10.2.9-3.fc27      fedora            36 k
 mariadb-libs            x86_64     3:10.2.9-3.fc27      fedora           150 k

Transaction Summary
================================================================================
Install  3 Packages
Upgrade  1 Package

Total size: 257 k
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] mariadb-libs-10.2.9-3.fc27.x86_64.rpm: Already downloaded            
[SKIPPED] mariadb-common-10.2.9-3.fc27.x86_64.rpm: Already downloaded          
[SKIPPED] mariadb-config-10.2.9-3.fc27.x86_64.rpm: Already downloaded          
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : mariadb-config-3:10.2.9-3.fc27.x86_64                  1/5 
  Installing       : mariadb-common-3:10.2.9-3.fc27.x86_64                  2/5 
  Installing       : mariadb-libs-3:10.2.9-3.fc27.x86_64                    3/5 
  Running scriptlet: mariadb-libs-3:10.2.9-3.fc27.x86_64                    3/5 
  Upgrading        : mariadb-connector-c-3.0.2-13.fc27.x86_64               4/5 
  Cleanup          : mariadb-connector-c-3.0.2-11.fc27.x86_64               5/5 
  Running scriptlet: mariadb-connector-c-3.0.2-11.fc27.x86_64               5/5 
  Verifying        : mariadb-libs-3:10.2.9-3.fc27.x86_64                    1/5 
  Verifying        : mariadb-common-3:10.2.9-3.fc27.x86_64                  2/5 
  Verifying        : mariadb-config-3:10.2.9-3.fc27.x86_64                  3/5 
  Verifying        : mariadb-connector-c-3.0.2-13.fc27.x86_64               4/5 
  Verifying        : mariadb-connector-c-3.0.2-11.fc27.x86_64               5/5 

Installed:
  mariadb-common.x86_64 3:10.2.9-3.fc27  mariadb-config.x86_64 3:10.2.9-3.fc27 
  mariadb-libs.x86_64 3:10.2.9-3.fc27   

Upgraded:
  mariadb-connector-c.x86_64 3.0.2-13.fc27                                      

Complete!
[root@localhost ~]# dnf install digikam
Last metadata expiration check: 0:02:31 ago on ma. 30. okt. 2017 kl. 17.38 +0100.
Dependencies resolved.
================================================================================
 Package                    Arch     Version                     Repository
                                                                           Size
================================================================================
Installing:
 digikam                    x86_64   5.7.0-2.fc27                fedora    71 M
Installing dependencies:
 bison                      x86_64   3.0.4-8.fc27                fedora   684 k
 digikam-libs               x86_64   5.7.0-2.fc27                fedora   7.5 M
 ebook-tools-libs           x86_64   0.2.2-10.fc27               fedora    31 k
 gpsd-libs                  x86_64   3.16-6.fc27                 fedora   111 k
 grantlee-qt5               x86_64   5.1.0-6.fc27                fedora   336 k
 kf5-akonadi-contacts       x86_64   17.08.1-1.fc27              fedora   570 k
 kf5-akonadi-server         x86_64   17.08.1-2.fc27              fedora   2.4 M
 kf5-attica                 x86_64   5.38.0-1.fc27               fedora   166 k
 kf5-kactivities-libs       x86_64   5.38.0-1.fc27               fedora   124 k
 kf5-kbookmarks             x86_64   5.38.0-1.fc27               fedora   165 k
 kf5-kcalendarcore          x86_64   17.08.1-1.fc27              fedora   297 k
 kf5-kcontacts              x86_64   17.08.1-1.fc27              fedora   287 k
 kf5-kdeclarative           x86_64   5.38.0-1.fc27               fedora   271 k
 kf5-kded                   x86_64   5.38.0-1.fc27               fedora    82 k
 kf5-kdelibs4support        x86_64   5.38.0-1.fc27               fedora   2.1 M
 kf5-kdelibs4support-libs   x86_64   5.38.0-1.fc27               fedora   831 k
 kf5-kdnssd                 x86_64   5.38.0-1.fc27               fedora   101 k
 kf5-kfilemetadata          x86_64   5.38.0-1.fc27               fedora   177 k
 kf5-kglobalaccel           x86_64   5.38.1-1.fc27               fedora    59 k
 kf5-kglobalaccel-libs      x86_64   5.38.1-1.fc27               fedora   108 k
 kf5-khtml                  x86_64   5.38.0-1.fc27               fedora   2.8 M
 kf5-kio-file-widgets       x86_64   5.38.0-1.fc27               fedora   269 k
 kf5-kipi-plugins-libs      x86_64   5.7.0-2.fc27                fedora   842 k
 kf5-kitemmodels            x86_64   5.38.0-1.fc27               fedora   109 k
 kf5-kjs                    x86_64   5.38.0-1.fc27               fedora   321 k
 kf5-kmime                  x86_64   17.08.1-1.fc27              fedora   161 k
 kf5-knewstuff              x86_64   5.38.0-1.fc27               fedora   581 k
 kf5-knotifyconfig          x86_64   5.38.0-1.fc27               fedora   107 k
 kf5-kpackage               x86_64   5.38.0-1.fc27               fedora   204 k
 kf5-kparts                 x86_64   5.38.0-1.fc27               fedora   209 k
 kf5-kpty                   x86_64   5.38.0-1.fc27               fedora    74 k
 kf5-krunner                x86_64   5.38.0-1.fc27               fedora   111 k
 kf5-kunitconversion        x86_64   5.38.0-1.fc27               fedora   944 k
 kf5-kwayland               x86_64   5.38.0-1.fc27               fedora   359 k
 kf5-kxmlgui                x86_64   5.38.0-1.fc27               fedora   787 k
 kf5-libkipi                x86_64   17.08.1-1.fc27              fedora   104 k
 kf5-libksane               x86_64   17.08.1-1.fc27              fedora   180 k
 kf5-plasma                 x86_64   5.38.0-1.fc27               fedora   4.4 M
 kf5-threadweaver           x86_64   5.38.0-1.fc27               fedora    72 k
 libXScrnSaver              x86_64   1.2.2-13.fc27               fedora    28 k
 liblqr-1                   x86_64   0.4.2-9.fc27                fedora    50 k
 libssh                     x86_64   0.7.5-3.fc27                fedora   201 k
 libzip                     x86_64   1.3.0-1.fc27                fedora    65 k
 m4                         x86_64   1.4.18-5.fc27               fedora   219 k
 marble-astro               x86_64   1:17.08.1-1.fc27            fedora   122 k
 marble-common              noarch   1:17.08.1-1.fc27            fedora    70 k
 marble-widget-data         noarch   1:17.08.1-1.fc27            fedora    14 M
 marble-widget-qt5          x86_64   1:17.08.1-1.fc27            fedora   3.7 M
 mariadb                    x86_64   3:10.2.9-3.fc27             fedora   6.7 M
 mariadb-errmsg             x86_64   3:10.2.9-3.fc27             fedora   223 k
 mariadb-server             x86_64   3:10.2.9-3.fc27             fedora    23 M
 openslp                    x86_64   2.0.0-14.fc27               fedora    81 k
 perl-DBD-MySQL             x86_64   4.043-5.fc27                fedora   151 k
 perl-DBI                   x86_64   1.637-1.fc27                fedora   734 k
 perl-Math-BigInt           noarch   1:1.9998.11-4.fc27          fedora   194 k
 perl-Math-Complex          noarch   1.59-401.fc27               fedora   103 k
 qt5-qtgraphicaleffects     x86_64   5.9.1-1.fc27                fedora   148 k
 qt5-qtlocation             x86_64   5.9.1-1.fc27                fedora   2.1 M
 qt5-qtquickcontrols        x86_64   5.9.1-1.fc27                fedora   1.1 M
 qt5-qtquickcontrols2       x86_64   5.9.1-1.fc27                fedora   818 k
 qt5-qtsensors              x86_64   5.9.1-1.fc27                fedora   212 k
 qt5-qtserialport           x86_64   5.9.1-1.fc27                fedora    73 k
 qt5-qtwebchannel           x86_64   5.9.1-1.fc27                fedora    80 k
 qt5-qtwebengine            x86_64   5.9.1-2.fc27                fedora    40 M
 qt5-qtwebkit               x86_64   5.212.0-0.7.alpha2.fc27     fedora    13 M
 re2                        x86_64   20160401-5.fc27             fedora   172 k
 shapelib                   x86_64   1.4.1-1.fc27                fedora    80 k
Installing weak dependencies:
 digikam-doc                noarch   5.7.0-2.fc27                fedora    20 M
 kf5-akonadi-server-mysql   x86_64   17.08.1-2.fc27              fedora    11 k
 kf5-kipi-plugins           x86_64   5.7.0-2.fc27                fedora   1.9 M
 kio-extras                 x86_64   17.08.1-1.fc27              fedora   1.2 M
 mariadb-server-utils       x86_64   3:10.2.9-3.fc27             fedora   2.3 M
 qt5-qtbase-mysql           x86_64   5.9.1-9.fc27                fedora    63 k
 qt5-qtimageformats         x86_64   5.9.1-1.fc27                fedora    98 k
Downgrading:
 kf5-kio-core               x86_64   5.38.0-1.fc27               fedora   636 k
 kf5-kio-core-libs          x86_64   5.38.0-1.fc27               fedora   486 k
 kf5-kio-doc                noarch   5.38.0-1.fc27               fedora   2.5 M
 kf5-kio-widgets            x86_64   5.38.0-1.fc27               fedora   261 k
 kf5-kio-widgets-libs       x86_64   5.38.0-1.fc27               fedora   396 k
 poppler                    x86_64   0.57.0-2.fc27               fedora   832 k
 poppler-glib               x86_64   0.57.0-2.fc27               fedora   148 k
 poppler-qt5                x86_64   0.57.0-2.fc27               fedora   178 k
 poppler-utils              x86_64   0.57.0-2.fc27               fedora   197 k
 qgnomeplatform             x86_64   0.3-4.fc27                  fedora    63 k
 qt5-qtbase                 x86_64   5.9.1-9.fc27                fedora   3.4 M
 qt5-qtbase-common          noarch   5.9.1-9.fc27                fedora    35 k
 qt5-qtbase-gui             x86_64   5.9.1-9.fc27                fedora   5.1 M
 qt5-qtdeclarative          x86_64   5.9.1-1.fc27                fedora   3.2 M
 qt5-qtscript               x86_64   5.9.1-1.fc27                fedora   1.1 M
 qt5-qtsvg                  x86_64   5.9.1-1.fc27                fedora   159 k
 qt5-qtx11extras            x86_64   5.9.1-1.fc27                fedora    30 k
 qt5-qtxmlpatterns          x86_64   5.9.1-1.fc27                fedora   1.1 M

Transaction Summary
================================================================================
Install    75 Packages
Downgrade  18 Packages

Total download size: 253 M

After installation completed i got this:

Installed:
  digikam.x86_64 5.7.0-2.fc27                                                   
  digikam-doc.noarch 5.7.0-2.fc27                                               
  kf5-akonadi-server-mysql.x86_64 17.08.1-2.fc27                                
  kf5-kipi-plugins.x86_64 5.7.0-2.fc27                                          
  kio-extras.x86_64 17.08.1-1.fc27                                              
  mariadb-server-utils.x86_64 3:10.2.9-3.fc27                                   
  qt5-qtbase-mysql.x86_64 5.9.1-9.fc27                                          
  qt5-qtimageformats.x86_64 5.9.1-1.fc27                                        
  bison.x86_64 3.0.4-8.fc27                                                     
  digikam-libs.x86_64 5.7.0-2.fc27                                              
  ebook-tools-libs.x86_64 0.2.2-10.fc27                                         
  gpsd-libs.x86_64 3.16-6.fc27                                                  
  grantlee-qt5.x86_64 5.1.0-6.fc27                                              
  kf5-akonadi-contacts.x86_64 17.08.1-1.fc27                                    
  kf5-akonadi-server.x86_64 17.08.1-2.fc27                                      
  kf5-attica.x86_64 5.38.0-1.fc27                                               
  kf5-kactivities-libs.x86_64 5.38.0-1.fc27                                     
  kf5-kbookmarks.x86_64 5.38.0-1.fc27                                           
  kf5-kcalendarcore.x86_64 17.08.1-1.fc27                                       
  kf5-kcontacts.x86_64 17.08.1-1.fc27                                           
  kf5-kdeclarative.x86_64 5.38.0-1.fc27                                         
  kf5-kded.x86_64 5.38.0-1.fc27                                                 
  kf5-kdelibs4support.x86_64 5.38.0-1.fc27                                      
  kf5-kdelibs4support-libs.x86_64 5.38.0-1.fc27                                 
  kf5-kdnssd.x86_64 5.38.0-1.fc27                                               
  kf5-kfilemetadata.x86_64 5.38.0-1.fc27                                        
  kf5-kglobalaccel.x86_64 5.38.1-1.fc27                                         
  kf5-kglobalaccel-libs.x86_64 5.38.1-1.fc27                                    
  kf5-khtml.x86_64 5.38.0-1.fc27                                                
  kf5-kio-file-widgets.x86_64 5.38.0-1.fc27                                     
  kf5-kipi-plugins-libs.x86_64 5.7.0-2.fc27                                     
  kf5-kitemmodels.x86_64 5.38.0-1.fc27                                          
  kf5-kjs.x86_64 5.38.0-1.fc27                                                  
  kf5-kmime.x86_64 17.08.1-1.fc27                                               
  kf5-knewstuff.x86_64 5.38.0-1.fc27                                            
  kf5-knotifyconfig.x86_64 5.38.0-1.fc27                                        
  kf5-kpackage.x86_64 5.38.0-1.fc27                                             
  kf5-kparts.x86_64 5.38.0-1.fc27                                               
  kf5-kpty.x86_64 5.38.0-1.fc27                                                 
  kf5-krunner.x86_64 5.38.0-1.fc27                                              
  kf5-kunitconversion.x86_64 5.38.0-1.fc27                                      
  kf5-kwayland.x86_64 5.38.0-1.fc27                                             
  kf5-kxmlgui.x86_64 5.38.0-1.fc27                                              
  kf5-libkipi.x86_64 17.08.1-1.fc27                                             
  kf5-libksane.x86_64 17.08.1-1.fc27                                            
  kf5-plasma.x86_64 5.38.0-1.fc27                                               
  kf5-threadweaver.x86_64 5.38.0-1.fc27                                         
  libXScrnSaver.x86_64 1.2.2-13.fc27                                            
  liblqr-1.x86_64 0.4.2-9.fc27                                                  
  libssh.x86_64 0.7.5-3.fc27                                                    
  libzip.x86_64 1.3.0-1.fc27                                                    
  m4.x86_64 1.4.18-5.fc27                                                       
  marble-astro.x86_64 1:17.08.1-1.fc27                                          
  marble-common.noarch 1:17.08.1-1.fc27                                         
  marble-widget-data.noarch 1:17.08.1-1.fc27                                    
  marble-widget-qt5.x86_64 1:17.08.1-1.fc27                                     
  mariadb.x86_64 3:10.2.9-3.fc27                                                
  mariadb-errmsg.x86_64 3:10.2.9-3.fc27                                         
  mariadb-server.x86_64 3:10.2.9-3.fc27                                         
  openslp.x86_64 2.0.0-14.fc27                                                  
  perl-DBD-MySQL.x86_64 4.043-5.fc27                                            
  perl-DBI.x86_64 1.637-1.fc27                                                  
  perl-Math-BigInt.noarch 1:1.9998.11-4.fc27                                    
  perl-Math-Complex.noarch 1.59-401.fc27                                        
  qt5-qtgraphicaleffects.x86_64 5.9.1-1.fc27                                    
  qt5-qtlocation.x86_64 5.9.1-1.fc27                                            
  qt5-qtquickcontrols.x86_64 5.9.1-1.fc27                                       
  qt5-qtquickcontrols2.x86_64 5.9.1-1.fc27                                      
  qt5-qtsensors.x86_64 5.9.1-1.fc27                                             
  qt5-qtserialport.x86_64 5.9.1-1.fc27                                          
  qt5-qtwebchannel.x86_64 5.9.1-1.fc27                                          
  qt5-qtwebengine.x86_64 5.9.1-2.fc27                                           
  qt5-qtwebkit.x86_64 5.212.0-0.7.alpha2.fc27                                   
  re2.x86_64 20160401-5.fc27                                                    
  shapelib.x86_64 1.4.1-1.fc27                                                  

Downgraded:
  kf5-kio-core.x86_64 5.38.0-1.fc27                                             
  kf5-kio-core-libs.x86_64 5.38.0-1.fc27                                        
  kf5-kio-doc.noarch 5.38.0-1.fc27                                              
  kf5-kio-widgets.x86_64 5.38.0-1.fc27                                          
  kf5-kio-widgets-libs.x86_64 5.38.0-1.fc27                                     
  poppler.x86_64 0.57.0-2.fc27                                                  
  poppler-glib.x86_64 0.57.0-2.fc27                                             
  poppler-qt5.x86_64 0.57.0-2.fc27                                              
  poppler-utils.x86_64 0.57.0-2.fc27                                            
  qgnomeplatform.x86_64 0.3-4.fc27                                              
  qt5-qtbase.x86_64 5.9.1-9.fc27                                                
  qt5-qtbase-common.noarch 5.9.1-9.fc27                                         
  qt5-qtbase-gui.x86_64 5.9.1-9.fc27                                            
  qt5-qtdeclarative.x86_64 5.9.1-1.fc27                                         
  qt5-qtscript.x86_64 5.9.1-1.fc27                                              
  qt5-qtsvg.x86_64 5.9.1-1.fc27                                                 
  qt5-qtx11extras.x86_64 5.9.1-1.fc27                                           
  qt5-qtxmlpatterns.x86_64 5.9.1-1.fc27                                         

I hope this is sufficient?

Thank you for your attention and for giving the problem such high priority.

Comment 13 Fedora Update System 2017-10-31 13:39:52 UTC
mariadb-connector-c-3.0.2-14.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d0a7b146a1

Comment 14 Fedora Update System 2017-10-31 13:40:22 UTC
mariadb-connector-c-3.0.2-14.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6a5f895018

Comment 15 Fedora Update System 2017-10-31 13:40:37 UTC
mariadb-connector-c-3.0.2-14.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e18ea35fe3

Comment 16 Fedora Update System 2017-10-31 19:10:36 UTC
mariadb-connector-c-3.0.2-14.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6a5f895018

Comment 17 Fedora Update System 2017-11-01 16:57:42 UTC
mariadb-connector-c-3.0.2-14.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e18ea35fe3

Comment 18 Fedora Update System 2017-11-01 17:22:35 UTC
mariadb-connector-c-3.0.2-14.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d0a7b146a1

Comment 19 Fedora Update System 2017-11-11 03:09:59 UTC
mariadb-connector-c-3.0.2-14.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2017-11-11 15:47:12 UTC
mariadb-connector-c-3.0.2-14.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2017-11-11 20:06:21 UTC
mariadb-connector-c-3.0.2-14.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.