Bug 150521 - Error on kickstart options page
Error on kickstart options page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Vlady Zlatkin
/network/systems/provisioning/kicksta...
:
Depends On:
Blocks: 147875 203074
  Show dependency treegraph
 
Reported: 2005-03-07 17:23 EST by Mike McCune
Modified: 2007-10-29 21:57 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHN 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-31 22:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2005-03-07 17:23:17 EST
Stacktrace found multiple times in production digests.  Need to figure out how
that data is getting in the database that would cause the error sent back.



Contents of this Digest Volume 2005-03-07 11:40

 WEB TRACEBACK from rhnserver4.app.phx.redhat.com (Mon Mar  7 11:39:43 2005)


Return-Path: <dev-null@rhn.redhat.com>
Received: from mx1.util.phx.redhat.com (mx1.util.phx.redhat.com [10.8.4.92])
    by alertmail.util.phx.redhat.com (8.11.6/8.11.6) with ESMTP id j27GdhM29759
    for <rhn-traceback@rhn.redhat.com>; Mon, 7 Mar 2005 11:39:43 -0500
Received: from rhnserver4.app.phx.redhat.com (nat-pool.util.phx.redhat.com
[10.8.5.200])
    by mx1.util.phx.redhat.com (8.11.6/8.11.6) with ESMTP id j27Gdik21666
    for <rhn-traceback@rhn.redhat.com>; Mon, 7 Mar 2005 11:39:44 -0500
Received: (from apache@localhost)
    by rhnserver4.app.phx.redhat.com (8.11.6/8.11.6) id j27GdhJ12563;
    Mon, 7 Mar 2005 11:39:43 -0500
Date: Mon, 7 Mar 2005 11:39:43 -0500
Message-Id: <200503071639.j27GdhJ12563@rhnserver4.app.phx.redhat.com>
To: rhn-traceback@rhn.redhat.com
From: Red Hat Network <dev-null@rhn.redhat.com>
Subject: WEB TRACEBACK from rhnserver4.app.phx.redhat.com (Mon Mar  7 11:39:43 2005)
Content-Type: text/plain; charset=US-ASCII
Errors-To: Red Hat Network <dev-null@rhn.redhat.com>
X-RHN-Email: rhn-traceback@rhn.redhat.com
X-RHN-Traceback-Severity: unhandled
Reply-to: rhn-traceback@redhat.com

The following exception occured while executing this request:
 POST /network/systems/provisioning/kickstarts/select_options.pxt HTTP/1.1 (from
browser)
 /network/systems/provisioning/kickstarts/select_options.pxt (from Apache)

Date:
  Mon Mar  7 11:39:43 2005

Headers:
  Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/x-shockwave-flash, application/vnd.ms-excel,
application/vnd.ms-powerpoint, application/msword, */*
  Accept-Language: en-us
  Cache-Control: no-cache
  Connection: close
  Content-Length: 1308
  Content-Type: application/x-www-form-urlencoded
  Cookie: rh_auth_token=4072812:1110213549xca941027b53b92f2de5fe0a05ba74510;
pxt-session-cookie=1354700380xe99b645b36b12677f12da0095bf43dcf
  Host: rhnapp.vip.phx.redhat.com
  Referer:
https://rhn.redhat.com/network/systems/provisioning/kickstarts/select_options.pxt
  User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR
1.1.4322; .NET CLR 1.0.3705)
  Via: 1.0 rhn.redhat.com
  X-ENV-HTTPS: on
  X-Forwarded-For: 161.49.11.1
  X-Host: rhn.redhat.com
  X-Proxy-Forwarded-For: 161.49.11.1
  X-Proxy-Forwarded-Host: rhn.redhat.com
  X-Proxy-Forwarded-Server: rhn.redhat.com
  X-Replace-Content-Active: 1
  X-Server-Hostname: rhn.redhat.com

Form variables:
  Create Kickstart => Create Kickstart
  active => Y
  bootloader => grub
  clearpart => --all
  default_kstree_id => 402
  dhcp_ip_iface => eth0
  formvar_hmac => 6544b67fe9063fa65efa8cd43ab33552648ce453
  kernel_params =>
  ks_ip_type => dhcp
  ksid =>
  label => MessageNet
  name => MessageNet
  partitions => part /boot --ondisk=hda --size=150 --asprimary --fstype=ext3
part pv.1 --ondisk=hda --size=29172
volgroup Volume00 pv.1
logvol / --fstype ext3 --name=lvroot --vgname=Volume00 --size=500
logvol /home --fstype ext3 --name=lvhome --vgname=Volume00 --size=2048
logvol /opt --fstype ext3 --name=lvopt --vgname=Volume00 --size=2048
logvol /tmp --fstype ext3 --name=lvtmp --vgname=Volume00 --size=2048
logvol /usr --fstype ext3 --name=lvusr --vgname=Volume00 --size=4096
logvol /usr/local --fstype ext3 --name=lvlocal --vgname=Volume00 --size=2048
logvol /var --fstype ext3 --name=lvvar --vgname=Volume00 --size=2048
logvol swap --fstype swap --name=lvswap --vgname=Volume00 --size=2048
logvol swap --fstype swap --name=lvswap2 --vgname=Volume00 --size=2048
  pxt:trap => rhn:kickstart-create-options-cb
  root_password_1 => xxx1
  root_password_2 => xxx1
  static_ip_iface =>
  success_redir => details.pxt
  timezone => America/New_York
  zerombr => yes

User Information:
  User slberger (id 4072812, org_id 4495503)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  A line with label 'swap' already exists. at
/usr/lib/perl5/site_perl/5.6.1/i386-linux/RHN/Kickstart/Multi.pm line 31.
Comment 1 Mike McCune 2005-03-07 17:24:10 EST
Robin indicated that this is like: 115029
Comment 2 Robin Norwood 2005-06-06 17:39:41 EDT
This should be a mustfix - should have already been fixed by bug #115029
Comment 3 Robin Norwood 2005-06-16 16:36:05 EDT
Fixed in CVS.

Test plan:

1) Create a new kickstart profile.
2) Either during creation, or afterwards, go to the 'Options' page for the ks
profile.
3) Enter the following value in the 'Partition Details' section:
'
part /boot --ondisk=hda --size=150 --asprimary --fstype=ext3
part pv.1 --ondisk=hda --size=29172
volgroup Volume00 pv.1
logvol / --fstype ext3 --name=lvroot --vgname=Volume00 --size=500
logvol /home --fstype ext3 --name=lvhome --vgname=Volume00 --size=2048
logvol /opt --fstype ext3 --name=lvopt --vgname=Volume00 --size=2048
logvol /tmp --fstype ext3 --name=lvtmp --vgname=Volume00 --size=2048
logvol /usr --fstype ext3 --name=lvusr --vgname=Volume00 --size=4096
logvol /usr/local --fstype ext3 --name=lvlocal --vgname=Volume00 --size=2048
logvol /var --fstype ext3 --name=lvvar --vgname=Volume00 --size=2048
logvol swap --fstype swap --name=lvswap --vgname=Volume00 --size=2048
logvol swap --fstype swap --name=lvswap2 --vgname=Volume00 --size=2048
'
(cut and paste everything between the quotes)
  - expect no 500 error when you click the submit button.

4) Go to the 'Details' tab, and click the 'View Kickstart' link
  - Expect to see a kickstart profile that looks 'right'.
Comment 4 Bret McMillan 2005-06-17 12:54:27 EDT
*** Bug 154687 has been marked as a duplicate of this bug. ***
Comment 5 Bret McMillan 2005-06-17 12:57:48 EDT
*** Bug 155243 has been marked as a duplicate of this bug. ***
Comment 6 Bret McMillan 2005-06-17 13:08:27 EDT
*** Bug 155904 has been marked as a duplicate of this bug. ***
Comment 7 Vlady Zlatkin 2005-07-08 17:18:21 EDT
fails qa, somewhat different, 2 /boot partitions.  I don't know why someone
would do this, but they shouldn't see a 500 if they do

  partitions => partition /boot --fstype=ext3 --size=200
partition swap --size=1000 --grow --maxsize=2000
partition / --fstype=ext3 --size=700 --grow
part /boot --ondisk=hda --size=150 --asprimary --fstype=ext3
part pv.1 --ondisk=hda --size=29172
volgroup Volume00 pv.1
logvol / --fstype ext3 --name=lvroot --vgname=Volume00 --size=500
logvol /home --fstype ext3 --name=lvhome --vgname=Volume00 --size=2048
logvol /opt --fstype ext3 --name=lvopt --vgname=Volume00 --size=2048
logvol /tmp --fstype ext3 --name=lvtmp --vgname=Volume00 --size=2048
logvol /usr --fstype ext3 --name=lvusr --vgname=Volume00 --size=4096
logvol /usr/local --fstype ext3 --name=lvlocal --vgname=Volume00 --size=2048
logvol /var --fstype ext3 --name=lvvar --vgname=Volume00 --size=2048
logvol swap --fstype swap --name=lvswap --vgname=Volume00 --size=2048
logvol swap --fstype swap --name=lvswap2 --vgname=Volume00 --size=2048
  pxt:trap => rhn:kickstart-create-options-cb
  root_password_1 => 
  root_password_2 => 
  static_ip_iface => 
  success_redir => select_options.pxt
  timezone => America/New_York
  zerombr => yes

User Information:
  User vz-temp (id 4095488, org_id 4631986)

Error notes:
  (none)

Initial Request:
  Yes

Error message:
  A line with label '/boot' already exists. at
/usr/lib/perl5/site_perl/5.8.5/RHN/Kickstart/Multi.pm line 31.
Comment 8 Robin Norwood 2005-07-12 09:52:00 EDT
Fixed in SVN.

Test plan:

o Create a kickstart profile, filling in the 'partitions' section with
partitions of the same 'label' - ie, /boot, /usr, etc.
  - Expect an error message:
"Only one /boot partition allowed"
* Note that multiple 'swap' partitions are specifically allowed, so this is legal:
"""
partition /boot --fstype=ext3 --size=200
partition swap --size=1000 --grow --maxsize=2000
partition / --fstype=ext3 --size=700 --grow
partition swap --size=100
"""
Comment 9 Vlady Zlatkin 2005-07-21 17:47:02 EDT
prod ready

Note You need to log in before you can comment on or make changes to this bug.