Bug 1505242
| Summary: | Engine fails to start when AddVmComman (start VM) job exists | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [oVirt] ovirt-engine | Reporter: | Meni Yakove <myakove> | ||||
| Component: | BLL.Network | Assignee: | Ravi Nori <rnori> | ||||
| Status: | CLOSED CURRENTRELEASE | QA Contact: | Meni Yakove <myakove> | ||||
| Severity: | high | Docs Contact: | |||||
| Priority: | high | ||||||
| Version: | 4.2.0 | CC: | bugs, danken, mburman, mperina, oourfali, rnori, tnisan | ||||
| Target Milestone: | ovirt-4.1.7 | Flags: | rule-engine:
ovirt-4.1+
rule-engine: blocker+ |
||||
| Target Release: | --- | ||||||
| Hardware: | x86_64 | ||||||
| OS: | Linux | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2017-11-13 12:28:36 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | Infra | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Attachments: |
|
||||||
|
Description
Meni Yakove
2017-10-23 06:31:59 UTC
According to the analysis, this is a network bug. If you need assistance from Infra, contact us. Moving to network. (In reply to Oved Ourfali from comment #1) > According to the analysis, this is a network bug. > If you need assistance from Infra, contact us. > Moving to network. Hi, @Depends on was added into MacPoolPerCluster, because it fails to initialize it's beans. In Roy Golans words: "Other beans that are not Backend must depend on it otherwise they might end up using some facilities which are not initilized." ~ Pools do not need Backend in any way, @DependsOn is there just because DI failed otherwise. This issue is Network related only in one way, failure is just happening here. So I think, that true reason is that Backend is severely overgrown (why should Backend do compensation on init?? Cannot that be done in separate bean? etc. etc.), and it should be broken down. Requirement, to use @Depends just to make DI work, is suggestion, that there is something infra-wrong. But I don't know what analysis you did and its results; please explain in greater depth why do you thinks it's network related. workaround: We shouldn't do it. But we can try (I don't know what happens then though) to remove @Startup from MacPoolPerCluster, leaving first initialization delay for the first customer. It shouldn't take long, but it was also multiple times decided, that we don't want to do that. Ravi, could you please help network team to fix that issue? Posted a patch to fix the issue I see the nature of the proposed fix is infra related, so moving back to infra. Verified on - 4.1.7.5-0.1.el7 |