Bug 1505282 - [RFE] ::Actions::Insights::EmailPoller to be automatically started on foreman-tasks startup, like e.g. LOCE is
Summary: [RFE] ::Actions::Insights::EmailPoller to be automatically started on foreman...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Tasks Plugin
Version: 6.2.12
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Jan Hutař
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-23 08:20 UTC by Pavel Moravec
Modified: 2019-06-03 12:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-03 12:05:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 21421 None None None 2017-10-23 08:22:29 UTC
Red Hat Bugzilla 1518576 None CLOSED Recurring tasks need to be more resilient 2019-05-14 18:44:50 UTC
Red Hat Knowledge Base (Solution) 3222051 None None None 2017-10-23 08:28:09 UTC

Internal Links: 1518576

Description Pavel Moravec 2017-10-23 08:20:28 UTC
Description of problem:
In case ::Actions::Insights::EmailPoller task is stopped (due to whatever error or user (wrong) intervention), (re)starting foreman-tasks service should ensure re-spawning the task.

This feature is already present for ListenOnCandlepinEevents (LOCE) task, as well as for MonitoQueue::Listener one. It should be available also for the last forever-running/pending task in Satellite.


Version-Release number of selected component (if applicable):
Sat 6.2.12


How reproducible:
100%


Steps to Reproduce:
1. Somehow stop that task, e.g. manually Cancel it
2. service foreman-tasks restart
3. Check if that task is running


Actual results:
An instance of that task type is running or scheduled, most probably it is in stopped/error state.


Expected results:
An instance of that task type should be in scheduled/pending state.


Additional info:

Comment 1 Adam Ruzicka 2017-10-23 08:22:27 UTC
Created redmine issue http://projects.theforeman.org/issues/21421 from this bug

Comment 2 Pavel Moravec 2017-10-23 08:28:10 UTC
Linking KCS with workaround.

Comment 5 Ivan Necas 2017-10-25 09:14:06 UTC
In that case, the tasks issue should describe the changes needed to be done one tasks side. Wouldn't the solution be insights using the same approach as LOCE?

Comment 6 Adam Ruzicka 2017-11-16 13:15:56 UTC
(In reply to Ivan Necas from comment #5)
> In that case, the tasks issue should describe the changes needed to be done on tasks side.
Makes sense, I'll file a new BZ which will block this one and turn this one over to Insights.

> Wouldn't the solution be insights using the same approach as LOCE?

Not really, LOCE and EQM should be running all the time. IEP is different, it should be triggered once a week and do some kind of one-shot action. We could convert it to an always-running action which would be suspended most of the time but I think it would cause more trouble than its worth.

Comment 7 Adam Ruzicka 2017-11-29 08:50:40 UTC
Created another BZ[1] to handle things on tasks side, leaving this BZ for changes which would need to go into insights.

Comment 8 Bryan Kearney 2019-05-02 19:06:45 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 9 Bryan Kearney 2019-06-03 12:05:23 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.