Bug 1505379 - [fix available] Opened combo box is blocking the entire session
Summary: [fix available] Opened combo box is blocking the entire session
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice
Version: 7.4
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-23 13:11 UTC by Martin Krajnak
Modified: 2018-04-10 12:05 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-10 12:04:37 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0751 None None None 2018-04-10 12:05 UTC

Description Martin Krajnak 2017-10-23 13:11:57 UTC
Description of problem:
While combo box for choosing style, font size or font type (Writer) is opened, I am unable to control any other window (firefox, hexchat) on other monitors, application itself cannot be minimized or closed via controls on top window panel, even Gnome shell activities, calendar and panel are not responsive.

Version-Release number of selected component (if applicable):
libreoffice-5.3.6.1-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Open Writer/Calc
2.Expand the combo box to change font style/size
3.Click on: Activities, Time/Date, Try to use other applications, try to close LO window

Actual results:
Gnome shell panel, desktop of any other application is not responsive.

Expected results:
User should be able to use gnome shell and other apps on other monitors after moving mouse above them.

Additional info:

Comment 2 Caolan McNamara 2017-10-24 15:52:55 UTC
Is this happening on real hardware, or in virt-viewer ?

Comment 3 Martin Krajnak 2017-10-24 16:02:43 UTC
yes, I can reproduce this on my 7.4 with LO libreoffice-5.3.6.1-2.el7.x86_64.

Comment 4 Martin Krajnak 2017-10-25 09:51:44 UTC
(In reply to Martin Krajnak from comment #3)
> yes, I can reproduce this on my 7.4 with LO libreoffice-5.3.6.1-2.el7.x86_64.

Sorry for inconvenience, I meant both real hardware and VM.

Comment 5 Caolan McNamara 2017-10-25 14:03:25 UTC
I think I see this locally on a RHEL-7 box, but same LibreOffice version on my Fedora 26 box doesn't show the same problem. I wonder where the difference lies.

Comment 6 Martin Krajnak 2017-10-27 07:59:21 UTC
I am not sure, but do you think that bug is not in libreoffice itself ? Is there a possibility that it might be caused by changes in gnome-shell ?

Comment 7 Caolan McNamara 2017-10-27 08:40:09 UTC
possibly, but I'm sure gnome-shell would immediately argue that libreoffice is wrong for being different to other gtk3 apps which don't exhibit the same problem

Comment 13 errata-xmlrpc 2018-04-10 12:04:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0751


Note You need to log in before you can comment on or make changes to this bug.