Bug 1505403 - List Clusters API call returns Internal Server Error after installation
Summary: List Clusters API call returns Internal Server Error after installation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-api
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Anup Nivargi
QA Contact: Rochelle
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-23 13:57 UTC by Filip Balák
Modified: 2017-12-18 04:39 UTC (History)
5 users (show)

Fixed In Version: tendrl-api-1.5.4-2.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github Tendrl api issues 306 None None None 2017-10-23 13:57:20 UTC
Github https://github.com/Tendrl api issues 306 None None None 2017-11-07 06:36:50 UTC

Description Filip Balák 2017-10-23 13:57:20 UTC
Description of problem:
Right after installation of tendrl with one cluster there is no cluster returned from API. API call for listing clusters `hostname/api/1.0/clusters` returns `500 Internal Server Error` message. API call starts to give correct response with cluster available to import after 2 minutes.

Version-Release number of selected component (if applicable):
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-ui-1.5.3-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.3-2.el7rhgs.noarch
tendrl-ansible-1.5.3-2.el7rhgs.noarch
tendrl-commons-1.5.3-1.el7rhgs.noarch
tendrl-api-1.5.3-2.el7rhgs.noarch
tendrl-api-httpd-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.3-2.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.3-3.el7rhgs.noarch
tendrl-notifier-1.5.3-1.el7rhgs.noarch
glusterfs-3.8.4-48.el7rhgs.x86_64


How reproducible:
100%


Steps to Reproduce:
1. Install Red Hat Gluster storage web administration with tendrl-ansible.
2. Look at status code and content returned from hostname/api/1.0/clusters in firebug on `Clusters` page.
or
run `curl -XGET -H "Authorization: Bearer
some_authorization_token" -H "Content-Type: application/json" http://hostname/api/1.0/clusters`


Actual results:
Server returns `500 Internal Server Error`. This behaviour remains for at least 2 minutes.

Expected results:
There should be probably returned not yet fully loaded cluster with some attribute indicating that the cluster is not yet ready and is being loaded. Or its loading status may be reflected somehow else by API but there shouldn't be any 5xx error code.

Additional info:

Comment 3 Petr Penicka 2017-11-08 14:03:06 UTC
Triage Nov 8: up for PM decision.

Comment 5 Rochelle 2017-11-19 07:57:12 UTC
Server does not return any errors including `500 Internal Server Error`.
Clusters are listed successfully. 

Verified with : tendrl-api-1.5.4-2.el7rhgs.noarch

Moving this bug to verified.

Comment 8 errata-xmlrpc 2017-12-18 04:39:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.