Bug 150548 - Installer hangs when loading aic7xxx module
Installer hangs when loading aic7xxx module
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-08 00:15 EST by root
Modified: 2012-06-20 11:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:54:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description root 2005-03-08 00:15:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
When trying to install RHEL4 on a machine with an Adaptec 2940 Ultra SCSI adaptor the install program freezes for a long time (over 10 minutes) on the 'loading aic7xxx module' message. 



Version-Release number of selected component (if applicable):
kernel-2.6.9-5ELSMP

How reproducible:
Always

Steps to Reproduce:
1.Boot off RHEL4 final release CD1
2.Press enter at RedHat boot prompt to accept default options (GUI install etc.)
3.
  

Actual Results:  The install froze for well over 30 minutes. Ctrl+Alt+F2 etc allowed switching between consoles. After an extended period of time the installer continued and RHEL4 installed correctly.

The last few lines on the Alt+F3 console were:
loaded e1000 from /modules/modules.cgz
loaded aic7xxx from /modules/modules.cgz
loaded libata from /modules/modules.cgz
loaded sata_sil from /modules/modules.cgz
loaded ata_piix from /modules/modules.cgz


Expected Results:  The installer should have immediately loaded the aic7xxx driver and proceded with the install - it should only have taken a few seconds.

Additional info:
Comment 1 root 2005-03-08 00:43:28 EST
Just tried it again - the actual time taken to get past the 'loading aic7xxx'
was 50 minutes!!! (+-5mins) and that was with passing the option 'linux
acpi=force' at boot time.
Comment 2 Dave Jones 2005-03-08 11:49:52 EST
I saw something very similar happen myself once, and the problem went away with
a system BIOS update. Can you check you have the latest from your vendor ?
Comment 3 root 2005-03-08 20:49:13 EST
I'm using a Tyan Tomcat i7210 S5112 mobo. It has the version 1.04 bios which is
the latest that was on the tyan.com website.
Comment 4 Philip Edelbrock 2005-05-23 19:43:08 EDT
I just updated my BIOS after reading this and the problem went away for me. 
I've got an Intel SCB2 in an RS2200 chassis.  When it was hanging before, I got
a message that said something like "Disabling IRQ interrupt 10".
Comment 5 oliver b. 2005-11-17 06:50:19 EST
While installing AS4 on an IBM IntelliStation (onboard AIC7899), I can reproduce 
the same error. 

When you were able to install RH just with some delay, I think you don't have 
any SCSI devices on the Adaptec!? I've waited more than half an hour and could 
see on another console (Alt-F3) that the system tried tu scan the SCSI IDs with 
reporting an error on each ID "no response, can't reset, exited with error code 
02x220,...". Even when the machine has booted after this torture, I hadn't any 
SCSI drives to installl RH on!

Today i'll check the BIOS version again, but I think, it's already the newest 
one.

Maybe you have some tricks for me, how you solved the problem if you couldn't do 
a BIOS update!?

Thanks in advance
Comment 6 oliver b. 2005-11-17 14:07:06 EST
The kernel option 'acpi=off' should solve this problem...
Comment 7 Jiri Pallich 2012-06-20 11:54:32 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.