Bug 150555 - missing module: mod_auth_ldap
missing module: mod_auth_ldap
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: httpd (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: FutureFeature
Depends On:
Blocks: 150589
  Show dependency treegraph
 
Reported: 2005-03-08 06:20 EST by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 10:03:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2005-03-08 06:20:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
Module mod_auth_ldap is not contained in base package and also not available as separate RPM - any reason?

Only mod_authz_ldap is available, but this has some missing features.

Version-Release number of selected component (if applicable):
httpd-2.0.46-44.ent

How reproducible:
Always

Steps to Reproduce:
1. install httpd
2. try to enable LDAP authentication

  

Actual Results:  fails

Expected Results:  mod_auth_ldap should be packaged, too, because it's provided and supported by Apache2

Additional info:
Comment 1 Suzanne Hillman 2005-03-08 14:43:54 EST
Internal RFE bug #150589 entered; will be considered for future releases.
Comment 2 Joe Orton 2005-09-12 10:03:08 EDT
The 2.0.46-level mod_auth_ldap/mod_ldap code was not deemed to be
production-ready, hence its omission from the httpd package in Red Hat
Enterprise Linux 3.

This problem is resolved in the next release of Red Hat Enterprise Linux. Red
Hat does not currently plan to provide a resolution for this in a Red Hat
Enterprise Linux update for currently deployed systems.

With the goal of minimizing risk of change for deployed systems, and in response
to customer and partner requirements, Red Hat takes a conservative approach when
evaluating changes for inclusion in maintenance updates for currently deployed
products. The primary objectives of update releases are to enable new hardware
platform support and to resolve critical defects. 

Note You need to log in before you can comment on or make changes to this bug.