Bug 1505573 - [modularity] module is not locked on the version installed but the latest
Summary: [modularity] module is not locked on the version installed but the latest
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 27
Hardware: Unspecified Unspecified
medium
high
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: dnf-modularity
TreeView+ depends on / blocked
 
Reported: 2017-10-23 21:42 UTC by Karel Srot
Modified: 2018-06-28 08:06 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-13 08:02:57 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karel Srot 2017-10-23 21:42:13 UTC
Description of problem:

When locking a module it is not locked on the version of the installed profile but the latest available one.

See below.

Version-Release number of selected component (if applicable):
dnf-2.7.5-4.fc26.modularity.1.3fb9e5c.git.8052.52e0d41None.noarch


[root@2245f7e719eb /]# dnf module install ModuleA:f26:1/default
Last metadata expiration check: 0:00:27 ago on Mon Oct 23 21:05:28 2017.
Dependencies resolved.
...
...
Complete!

[root@2245f7e719eb /]# dnf module list --installed
Last metadata expiration check: 0:00:41 ago on Mon Oct 23 21:05:28 2017.
modularityABDE
Name                            Stream                         Version                         Profiles                                       
ModuleA                         f26                            1                               client, default [i], ...                       

Hint: [d]efault, [i]nstalled, [l]ocked

[root@2245f7e719eb /]# dnf module lock ModuleA
Last metadata expiration check: 0:01:22 ago on Mon Oct 23 21:05:28 2017.
'ModuleA' is locked (stream: f26, version: 2)
[root@2245f7e719eb /]# dnf module list --installed
Last metadata expiration check: 0:01:26 ago on Mon Oct 23 21:05:28 2017.
modularityABDE
Name                            Stream                         Version                         Profiles                                       
ModuleA                         f26                            2 [l]                           client, default [i], ...                       

Hint: [d]efault, [i]nstalled, [l]ocked

Comment 1 Martin Hatina 2017-10-25 08:38:01 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/969

Comment 2 Jaroslav Mracek 2018-06-28 08:06:20 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.