Bug 1505574 - [modularity] can't install additional profiles when module is locked
Summary: [modularity] can't install additional profiles when module is locked
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 27
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: 1478068
TreeView+ depends on / blocked
 
Reported: 2017-10-23 21:47 UTC by Karel Srot
Modified: 2018-06-28 08:05 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-03-13 08:03:06 UTC


Attachments (Terms of Use)

Description Karel Srot 2017-10-23 21:47:13 UTC
Description of problem:

When the module is locked I can't install additional profiles.

See below.

Version-Release number of selected component (if applicable):
dnf-2.7.5-4.fc26.modularity.1.3fb9e5c.git.8052.52e0d41None.noarch


[root@94a983115537 /]# dnf module install ModuleA:f26:2/client
Last metadata expiration check: 0:00:31 ago on Mon Oct 23 21:45:00 2017.
Dependencies resolved.
========================================================================================
 Package          Arch              Version             Repository                 Size
========================================================================================
Installing module packages:
 TestA            noarch            1-2.modA            modularityABDE            5.5 k
 TestB            noarch            1-1.modA            modularityABDE            5.5 k

Transaction Summary
========================================================================================

Total size: 11 k
Installed size: 0  
Is this ok [y/N]: N
Operation aborted.
[root@94a983115537 /]# dnf module lock ModuleA:f26
Last metadata expiration check: 0:00:41 ago on Mon Oct 23 21:45:00 2017.
'ModuleA:f26' is locked (stream: f26, version: 2)
[root@94a983115537 /]# dnf module install ModuleA:f26:2/client
Last metadata expiration check: 0:00:44 ago on Mon Oct 23 21:45:00 2017.
'ModuleA' is locked to version: 2
Nothing to install. Enabled modules: ModuleA:f26

There is a similar issue with removing profiles however that might be related to a situation when not the latest profile version is installed.

Comment 1 Martin Hatina 2017-10-25 08:37:40 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/969

Comment 2 Karel Srot 2017-10-26 08:00:23 UTC
based on module-lock-unlock-2 test results this seems to be fixed

Comment 3 Jaroslav Mracek 2018-06-28 08:05:59 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.