Bug 1505577 - [modularity] I can disable the locked module
Summary: [modularity] I can disable the locked module
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: 27
Hardware: Unspecified Unspecified
medium
medium
Target Milestone: ---
Assignee: Martin Hatina
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: dnf-modularity
TreeView+ depends on / blocked
 
Reported: 2017-10-23 21:54 UTC by Karel Srot
Modified: 2018-06-28 08:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-13 08:03:19 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Karel Srot 2017-10-23 21:54:14 UTC
Description of problem:

I can disable a locked module. According to detailed functional requirements specification this should not be possible.

See below.

Version-Release number of selected component (if applicable):
dnf-2.7.5-4.fc26.modularity.1.3fb9e5c.git.8052.52e0d41None.noarch

[root@ac872f34caa2 /]# dnf module enable ModuleA:f26
Last metadata expiration check: 0:00:20 ago on Mon Oct 23 21:51:11 2017.
'ModuleA:f26' is enabled
[root@ac872f34caa2 /]# dnf module lock ModuleA      
Last metadata expiration check: 0:00:29 ago on Mon Oct 23 21:51:11 2017.
'ModuleA' is locked (stream: f26, version: 2)
[root@ac872f34caa2 /]# dnf module disable ModuleA
Last metadata expiration check: 0:00:36 ago on Mon Oct 23 21:51:11 2017.
'ModuleA' is disabled
[root@ac872f34caa2 /]# dnf module list
Last metadata expiration check: 0:00:42 ago on Mon Oct 23 21:51:11 2017.
modularityABDE
Name                Stream            Version            Profiles                       
ModuleA             f26               2 [l]              client, default, ...           
ModuleB             f26               2                  default                        
ModuleD             f26               1                  default                        
ModuleE             f26               1                  default                        

Hint: [d]efault, [i]nstalled, [l]ocked
[root@ac872f34caa2 /]# cat /etc/dnf/modules.d/ModuleA.module 
[ModuleA]
locked = 1
name = ModuleA
stream = f26
enabled = 0
profiles =
version = 2

Comment 1 Martin Hatina 2017-10-25 08:36:01 UTC
Fixed by https://github.com/rpm-software-management/dnf/pull/969

Comment 2 Karel Srot 2017-10-26 08:02:45 UTC
according to the respective scenario from module-lock-unlock-3 this seems to be fixed.

Comment 3 Jaroslav Mracek 2018-06-28 08:05:35 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.