Bug 15057 - Mounting ls120: ide-floppy: hdc: I/O error
Mounting ls120: ide-floppy: hdc: I/O error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Florence Gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-01 16:23 EDT by giulioo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 14:03:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-08-01 16:23:18 EDT
Pinstripe (or maybe it was b4) is the first rh beta which correctly sets 
up an entry for the ls120 in /etc/fstab.

So, please, go one step further and shut up the kernel when it outputs the

kernel:  hdc: unknown partition table
kernel:  hdc: unknown partition table
kernel:  hdc: unknown partition table

messages to the console when mounting an ls120 (with a file system on it).
Comment 1 giulioo 2000-08-18 12:06:55 EDT
Linuxconf in rc1 accesses the ls120 everytime you exit, so that everytime I 
see "hdc: unknown partition table" popping up over the last linuxconf screen.
Comment 2 Alan Cox 2000-09-16 18:43:44 EDT
--- drivers/block/genhd.c~	Fri Sep  1 13:32:19 2000
+++ drivers/block/genhd.c	Sat Sep 16 23:12:17 2000
@@ -1516,7 +1516,7 @@
 	char buf[MAX_DISKNAME_LEN];
 
 	if (first_time)
-		printk("Partition check:\n");
+		printk(KERN_INFO "Partition check:\n");
 	first_time = 0;
 	first_sector = hd->part[MINOR(dev)].start_sect;
 
@@ -1529,7 +1529,7 @@
 		return;
 	}
 
-	printk(" %s:", disk_name(hd, MINOR(dev), buf));
+	printk(KERN_INFO " %s:", disk_name(hd, MINOR(dev), buf));
 #ifdef CONFIG_MSDOS_PARTITION
 	if (msdos_partition(hd, dev, first_sector))
 		return;
Comment 3 giulioo 2000-09-18 07:09:33 EDT
Ok, this fixes the ls120 problem, thanks. So this bug can be closed.


Now I see there's another problem with linuxconf which I'll file in
bugzilla when I get rh70 (since I'm still on rc1 and don't now if this
has been fixed).

The problem manifests only when I configure the ide cdrw:
1) modules.conf  
options ide-cd ignore=hdd
2) modprobe ide-scsi

Then every time I exit linuxconf I get (on console and messages)
kernel: ide-scsi: hdd: unsupported command in request queue (0)
kernel: end_request: I/O error, dev 16:40 (hdd), sector 0

[root@i5 /dev]# grep cdrom /etc/fstab
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
[root@i5 /dev]# ls -l /dev/cdrom
lrwxrwxrwx    1 root     root            4 set 18 13:03 /dev/cdrom -> scd0
Comment 4 giulioo 2000-12-06 06:39:10 EST
The proposed kernel modification solves the problem, but it's not in rh70 
final. So this still needs to be addressed in future versions.
Comment 5 Glen Foster 2001-01-11 16:03:01 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 6 Michael K. Johnson 2001-01-12 09:50:05 EST
That patch will be in the next 2.2-based errata from Red Hat.
I don't think it's necessary for the 2.4 kernels (genhd.c has
changed wildly and at least that prink line isn't in that
directory at all) but if it is please open a new bug report
for the 2.4 kernels.  Thanks!
Comment 7 giulioo 2001-02-09 12:11:29 EST
Beta2 was ok.

Beta3 is angry again: every time I access the ls120 (tar to/from it, mount it, 
quit linuxconf) I get this messages on console:
ide-floppy: hdc: I/O error, pc = 5a, key =  5, asc = 24, ascq =  0

in /var/log/messages there is also
hdc: unknown partition table
Comment 8 Arjan van de Ven 2001-02-09 14:03:52 EST
Can you try the updated kernel (either via up2date or from the rawhide
directory on ftp.redhat.com)? It should have a fix for this.
Comment 9 giulioo 2001-02-09 14:38:55 EST
Ok, rawhide kernel does not clutter the console, just "unknown partition table" 
in messages.

Note You need to log in before you can comment on or make changes to this bug.