Bug 1505731 - Upgrading poppler from updates-testing repo fails because of dependency problems
Summary: Upgrading poppler from updates-testing repo fails because of dependency problems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: poppler
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Tardon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1502335 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-24 08:04 UTC by Joachim Backes
Modified: 2017-11-07 22:15 UTC (History)
14 users (show)

Fixed In Version: poppler-0.52.0-9.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-07 22:15:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Joachim Backes 2017-10-24 08:04:14 UTC
Description of problem:
Trying to update to poppler-0.52.0-8.fc26 is rejected because of dependencies

Version-Release number of selected component (if applicable):

 poppler-qt5-0.52.0-8.fc26.x86_64

How reproducible:

always
Steps to Reproduce:
1. sudo dnf upgrade  poppler --enablerepo=updates-testing
2.
3.

Actual results:

Dependencies resolved.

 Problem: problem with installed package mscore-2.1.0-2.fc26.x86_64
  - package mscore-2.1.0-2.fc26.x86_64 requires qt5-qtbase(x86-64) = 5.7.1, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.9.2-1.fc26.x86_64 and qt5-qtbase-5.7.1-19.fc26.x86_64
  - cannot install both qt5-qtbase-5.7.1-19.fc26.x86_64 and qt5-qtbase-5.9.2-1.fc26.x86_64
  - cannot install both qt5-qtbase-5.7.1-15.fc26.x86_64 and qt5-qtbase-5.9.2-1.fc26.x86_64
  - package poppler-qt5-0.52.0-8.fc26.x86_64 requires libQt5Core.so.5(Qt_5.9)(64bit), but none of the providers can be installed
  - problem with installed package poppler-qt5-0.52.0-5.fc26.x86_64
  - package poppler-qt5-0.52.0-5.fc26.x86_64 requires poppler(x86-64) = 0.52.0-5.fc26, but none of the providers can be installed
  - cannot install both poppler-0.52.0-8.fc26.x86_64 and poppler-0.52.0-5.fc26.x86_64
  - cannot install both poppler-0.52.0-5.fc26.x86_64 and poppler-0.52.0-8.fc26.x86_64
  - cannot install the best update candidate for package poppler-0.52.0-5.fc26.x86_64
================================================================================================================================
 Package                       Arch                     Version                         Repository                         Size
================================================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 poppler                       x86_64                   0.52.0-8.fc26                   updates-testing                   830 k
 qt5-qtbase                    x86_64                   5.7.1-15.fc26                   fedora                            3.0 M
 qt5-qtbase                    x86_64                   5.9.2-1.fc26                    updates-testing                   3.3 M
Skipping packages with broken dependencies:
 poppler-qt5                   x86_64                   0.52.0-8.fc26                   updates-testing                   174 k

Transaction Summary
================================================================================================================================
Skip  4 Packages

Expected results:


Additional info:

Comment 1 David Tardon 2017-10-24 09:34:19 UTC
qt5 5.9.2 update was pushed to stable today...

Comment 2 Fedora Update System 2017-10-24 09:59:27 UTC
poppler-0.52.0-9.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-51ff8fe326

Comment 3 Rex Dieter 2017-10-24 19:00:39 UTC
Comment #1 is incorrect.  qt 5.9.2 is still in updates-testing:
https://bodhi.fedoraproject.org/updates/FEDORA-2017-c133443edc

fyi, 
poppler-0.52.0-8 was built against qt 5.9.2
poppler-0.52.0-9 was built against qt 5.7.1

so -9 build should be safe to use (and you don't need to wait for 5.9.2 to stable)

See also bug #1502335

Comment 4 Rex Dieter 2017-10-24 19:01:47 UTC
*** Bug 1502335 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2017-10-26 01:32:29 UTC
poppler-0.52.0-9.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-51ff8fe326

Comment 6 Fedora Update System 2017-11-07 22:15:41 UTC
poppler-0.52.0-9.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.