Bug 1505757 - Sample command in oc new-app help page not work
Summary: Sample command in oc new-app help page not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.7.0
Assignee: Ben Parees
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-24 08:53 UTC by Wenjing Zheng
Modified: 2017-12-18 13:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-18 13:22:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description Wenjing Zheng 2017-10-24 08:53:42 UTC
Description of problem:
When check the help page of oc new-app, there is a sample command: oc new-app https://github.com/openshift/ruby-hello-world#beta4, but it doesn't work for error: 
Step 7 : RUN scl enable ror40 "bundle install"
 ---> Running in 439938beb1b8
Bundler::GemfileNotFound
error: build error: The command '/bin/sh -c scl enable ror40 "bundle install"' returned a non-zero code: 10


Version-Release number of selected component (if applicable):
oc v3.7.0-0.162.0
kubernetes v1.7.6+a08f5eeb62
features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible:
always

Steps to Reproduce:
1. oc new-app --help
2. oc new-app https://github.com/openshift/ruby-hello-world#beta4
3.

Actual results:
Build failed when using sample command in help page of oc new-app

Expected results:
It should succeed.

Additional info:

Comment 1 Ben Parees 2017-11-29 16:59:39 UTC
beta4 branch has been fixed.

Comment 2 Wenjing Zheng 2017-12-04 06:41:09 UTC
Verified with below version:
openshift v3.7.11
kubernetes v1.7.6+a08f5eeb62
etcd 3.2.8

Comment 5 errata-xmlrpc 2017-12-18 13:22:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.