Bug 150579 - ifup-ipsec not working with manual keying
ifup-ipsec not working with manual keying
Status: CLOSED DUPLICATE of bug 150552
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2005-03-08 12:13 EST by Daniel Riek
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-03-31 16:00:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Daniel Riek 2005-03-08 12:13:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.5) Gecko/20041216 Firefox/1.0 Red Hat/1.0-13.EL4

Description of problem:
Even with a correct ifcfg for ipsec with manual keying ifup-ipsec fails to activate the encryption. The real bug is a pair '"' put around every key in the call to setkey, that leads to an error. The secondary problem is that the failure of this call is not detected.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Configure ifcfg for ipsec with manual keying
2. ifup ipsec interface
3. setkey -D

Actual Results:  No keys set

Expected Results:  Keys set

Additional info:

Resolution for the primary problem would be to remove all $(echo '"') around the KEY...s. Resolution for the secondary problem would be evaluation of the setkey exit codes.
Comment 1 Bill Nottingham 2005-03-11 16:55:49 EST
I can't reproduce this here. Can you attach your config file?
Comment 2 Bill Nottingham 2005-03-31 16:00:57 EST
Marking as a duplicate of the presumed issue you're running into.

*** This bug has been marked as a duplicate of 150552 ***

Note You need to log in before you can comment on or make changes to this bug.