Bug 150583 - nmbd dies when windows client requests browse list
nmbd dies when windows client requests browse list
Status: CLOSED DUPLICATE of bug 150582
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-08 13:02 EST by Jerry U. "
Modified: 2014-08-31 19:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry U. " 2005-03-08 13:02:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6)
Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
nmbd dies a random interval after starting. Usually when a windows
client tries to browse the net.

The samba server is the local browse master, and a domain member
server, but not a PDC. The PDC is on another subnet, outside of a
firewall. Error does not occur when the samba server is not the local
browse master. 

iptables is stopped and SELinux is disabled. Problem still occurs.

The nmbd log states :
[2005/03/08 11:32:34, 0] nmbd/nmbd.c:main(669)
  Netbios nameserver version 3.0.10-1.4E started.
  Copyright Andrew Tridgell and the Samba Team 1994-2004
[2005/03/08 11:32:57, 0]
nmbd/nmbd_become_lmb.c:become_local_master_stage2(396)
  *****

  Samba name server TME is now a local master browser for workgroup
SPENG on sub
net 192.168.35.40

  *****
[2005/03/08 11:46:48, 0] lib/fault.c:fault_report(36)
  ===============================================================
[2005/03/08 11:46:48, 0] lib/fault.c:fault_report(37)
  INTERNAL ERROR: Signal 11 in pid 5724 (3.0.10-1.4E)
  Please read the appendix Bugs of the Samba HOWTO collection
[2005/03/08 11:46:48, 0] lib/fault.c:fault_report(39)
  ===============================================================
[2005/03/08 11:46:48, 0] lib/util.c:smb_panic2(1504)
  PANIC: internal error
[2005/03/08 11:46:48, 0] lib/util.c:smb_panic2(1512)
  BACKTRACE: 7 stack frames:
   #0 nmbd(smb_panic2+0x6e) [0x552ab3d54e]
   #1 nmbd [0x552ab2b851]
   #2 /lib64/tls/libc.so.6 [0x2a962f9570]
   #3 nmbd(expire_workgroups_and_servers+0x36) [0x552aaeba26]
   #4 nmbd(main+0x597) [0x552aad3897]
   #5 /lib64/tls/libc.so.6(__libc_start_main+0xea) [0x2a962e74ca]
   #6 nmbd [0x552aad232a]




Version-Release number of selected component (if applicable):
samba-3.0.10-1.4E

How reproducible:
Always

Steps to Reproduce:
1. Make samba server local browse master, pdc on other subnet, no pdc
or bdc on subnet
2.
3.
    

Actual Results:  smb status reports
nmbd dead but pid file exists


Expected Results:  smb status should report
nmbd (pid 5724) is running...

Additional info:

relevant lines from smb.conf
    remote browse sync = four separate ip adresses, removed
   local master = yes
   preferred master = yes
    os level = 65


   security = domain


I searched for a similar error being reported, but didn't find any.
Comment 1 Jay Fenlason 2005-03-08 16:05:42 EST

*** This bug has been marked as a duplicate of 150582 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.