Bug 150584 - sysreport does not properly handle sparse files
sysreport does not properly handle sparse files
Status: CLOSED DUPLICATE of bug 156858
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysreport (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2005-03-08 13:39 EST by Chris Snook
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-09 11:47:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Chris Snook 2005-03-08 13:39:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
When sysreport attempts to tar a directory that contains sparse files that appear much larger than they are (have data at high addresses), such as core files, it does not use 'tar -S' to handle the sparse files efficiently.  Tar will attempt to create several-gigabyte files even though the actual data may only be kilobytes in size.  Observed on RHEL 3 U2, though the changelog shows no changes that should have an impact on this behavior.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create sparse files with data at high addresses in directories that sysreport collects
2. run sysreport


Actual Results:  tar attempts to create huge tar files, takes a very long time to run, and possibly runs out of memory and/or disk space

Expected Results:  tar should have been invoked with the -S flag, and the sparse files should be included in an efficient manner.

Additional info:

While there is an easy workaround (separately collecting and deleting sparse files prior to running sysreport), users may not be aware of why sysreport is failing.  Since sysreport is typically run on already troubled systems, this may mislead debugging attempts.  I'm classifying this as Normal severity, since the workaround, while simple, is not obvious to many users.
Comment 1 Ngo Than 2005-05-09 11:47:24 EDT

*** This bug has been marked as a duplicate of 156858 ***

Note You need to log in before you can comment on or make changes to this bug.