Bug 150588 - No error reported when workspace is in use.
Summary: No error reported when workspace is in use.
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
: 155755 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-08 19:39 UTC by Jeff Pound
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-09 18:00:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 21372 None None None Never

Description Jeff Pound 2005-03-08 19:39:55 UTC
Description of problem:
When you try to launch eclipse with a workspace which is in use, eclipse just
hangs at the splash screen stage.

Version-Release number of selected component (if applicable):
3.1.0_fc-0.M5.10

How reproducible:
always

Steps to Reproduce:
1. Start eclipse (or a runtime workbench)
2. Start eclipse again w/ the same workspace (or launch the runtime workbench again)

  
Actual results:
Eclipse hangs at the splash screen stage. Eventually the splash screen will go
away but the process is still running. If the first instance of eclipse is shut
down the hanging one will start up.

Expected results:
A "Workspace is currently in use" error should be shown.

Comment 1 Billy Biggs 2005-04-21 23:11:20 UTC
This is probably because the osgi.locking property is being shut off.

Comment 2 Andrew Overholt 2005-04-22 15:47:39 UTC
Where is it being shut off?  We used to do this in our launching script but not
any more.

Jeff, does this still happen?  I think it might 'cause Anthony Green just
reported similar behaviour.

Comment 3 Jeff Pound 2005-04-22 16:41:58 UTC
This is still happening as of 0.M5.12

Comment 4 Andrew Overholt 2005-04-22 17:51:05 UTC
When you can, please try with the M6 packages.

Comment 5 Andrew Overholt 2005-04-22 20:14:02 UTC
*** Bug 155755 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Pound 2005-04-27 19:42:11 UTC
This no longer happens when launching 2 run-time workbenches. It does however,
still happen when launching two separate eclipse instances with the same workspace.

Comment 7 Jeff Pound 2005-04-27 19:44:01 UTC
forgot to mention verion: 3.1.0_fc-0.M6.12

Comment 8 Andrew Overholt 2005-04-27 19:50:12 UTC
Does this happen with upstream + proprietary JVM?

Comment 9 Jeff Pound 2005-04-27 19:53:29 UTC
Andrew, upstream M6 + proprietary JVM reports the "workspace in use" error

Comment 10 Andrew Overholt 2005-05-04 03:19:02 UTC
I tracked this down to a libgcj/classpath bug.  It's fixed upstream, but we'll
have to get the patch into our gcc RPMs.

Comment 11 Andrew Overholt 2005-05-09 18:00:18 UTC
This patch is in gcc* >= 4.0.0-4.

Closing RAWHIDE even though this hasn't been pushed yet.


Note You need to log in before you can comment on or make changes to this bug.