Bug 150599 - building of gcc-3.4.2-6.fc3 src.rpm fails
building of gcc-3.4.2-6.fc3 src.rpm fails
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-08 15:41 EST by Paul Bolle
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-09 05:04:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Bolle 2005-03-08 15:41:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Building of gcc-3.4.2-6.fc3 from gcc-3.4.2-6.fc3.src.rpm (only adding a trivial "one line patch" I wanted to test) failed on my system (running kernel-2.6.10-1.766_FC3).



Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3

How reproducible:
Always

Steps to Reproduce:
1. try to build gcc-3.4.2-6.fc3 from gcc-3.4.2-6.fc3.src.rpm
2.
3.
  

Actual Results:  Build errors (libtool complaining: "Argument list too long").

Expected Results:  No build errors.

Additional info:

I stored the the output of rpmbuild in a file (rpmbuild -bb gcc-3.4.2-6.fc3.src.rpm 2>&1 | tee gcc34)

grep "Argument list" gcc34 gives:
./libtool: line 3587: /usr/bin/expr: Argument list too long
./libtool: line 3621: /usr/bin/expr: Argument list too long
./libtool: line 3621: /usr/bin/expr: Argument list too long
./libtool: line 3665: /usr/bin/ld: Argument list too long

This might very well be something trivial in my setup, but I couldn't find a clue how to solve this so I decided to file this bugreport.
Comment 1 Jakub Jelinek 2005-03-09 05:04:05 EST
Can't reproduce, sorry.

Note You need to log in before you can comment on or make changes to this bug.