Bug 1506100 - Unable to specify IP address for websocket to bind to
Summary: Unable to specify IP address for websocket to bind to
Keywords:
Status: CLOSED DUPLICATE of bug 1498964
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: lpeer
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-25 06:35 UTC by Josh Hershberg
Modified: 2018-10-24 12:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-11-02 09:24:23 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Josh Hershberg 2017-10-25 06:35:18 UTC
Upstream: https://bugs.opendaylight.org/show_bug.cgi?id=9256

By default the websocket server will listen on 0.0.0.0 which is not acceptable in a clustered environment where we are using haproxy to bind a virtual IP for ODL and load balance websocket connections.  It is also unsafe to bind to 0.0.0.0.  There is currently no way to specify the IP address to bind to, only config available is to change the port.

Comment 1 Janki 2017-11-02 09:24:23 UTC

*** This bug has been marked as a duplicate of bug 1498964 ***


Note You need to log in before you can comment on or make changes to this bug.