Bug 1506361 - Log Spam: error syncing image
Summary: Log Spam: error syncing image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Master
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.7.0
Assignee: Michal Fojtik
QA Contact: Mike Fiedler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-25 19:16 UTC by Vikas Laad
Modified: 2017-12-18 13:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 13:23:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3464 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.7 bug fix and enhancement update 2017-12-18 18:22:05 UTC

Description Vikas Laad 2017-10-25 19:16:38 UTC
Description of problem:
I see following error in logs very frequently, I have master api and controller loglevel=2. Not sure if its a problem with quickstart app or just spam in logs. Builds are working fine and dont see any errors also in build logs.

following logs are from cluster where openshift is running as system containers
Oct 25 18:28:52 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:52.662393    1429 signature_import_controller.go:109] error syncing image sha256:9f7a778a8998bcf485c02b4b24c642edebcba4f994ccf68c8c83798939a8cc0e, it will be retried: unauthorized: authentication required
Oct 25 18:28:52 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:52.959774    1429 signature_import_controller.go:109] error syncing image sha256:a04b5138ebe00bda1c460e85ba294bae06795f88eabc0d3ce51ff6cc97b5afbd, it will be retried: unauthorized: authentication required
Oct 25 18:28:52 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:52.997275    1429 signature_import_controller.go:109] error syncing image sha256:a48d43916e7373bda1176e113f18f2fc16e1061a1dfd644ee509ac29ed8b231f, it will be retried: unauthorized: authentication required
Oct 25 18:28:54 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:54.264674    1429 signature_import_controller.go:109] error syncing image sha256:c194bf28e4fc73b5ad645967f2ec9f8fae56ff613dae6bdde6324cf701ec16b5, it will be retried: unauthorized: authentication required
Oct 25 18:28:54 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:54.292121    1429 signature_import_controller.go:109] error syncing image sha256:c2e73c4acefb40411e8af38f10feec4efba0c294fa25d87ecf52b7dfce61a86d, it will be retried: unauthorized: authentication required
Oct 25 18:28:55 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:55.259540    1429 signature_import_controller.go:109] error syncing image sha256:d398c3dab3a43afbf885d2ee058a16bdcd782e13af23091349edb3cab190c5da, it will be retried: unauthorized: authentication required
Oct 25 18:28:55 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:55.522048    1429 signature_import_controller.go:109] error syncing image sha256:d7c7bea2d4d781613bd33f20ab2a45ccd5fa5e7f90303a6786b3e8946f67c67f, it will be retried: unauthorized: authentication required
Oct 25 18:28:55 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:55.685891    1429 signature_import_controller.go:109] error syncing image sha256:de74b5606fc3b8349822f9541dd5fe04b511da92052ea4e24ab55037d365c442, it will be retried: unauthorized: authentication required
Oct 25 18:28:55 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:55.959690    1429 signature_import_controller.go:109] error syncing image sha256:e6591b2623e7f812dd1248c8744b6ba31486a0505b2bc2ae74e1508a2494884e, it will be retried: unauthorized: authentication required
Oct 25 18:28:56 ip-172-31-29-26.us-west-2.compute.internal atomic-openshift-master-controllers[1214]: E1025 18:28:56.754247    1429 signature_import_controller.go:109] error syncing image sha256:f6b8b86c82926d1f21a782e187f5a2b4aee5e4ea74e9b77d7a2e5f291aed9fa3, it will be retried: unauthorized: authentication required

following logs are from cluster where openshift is installed using rpms
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.057269   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.078924   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.102982   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.137312   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.192469   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.287013   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.461618   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:19 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:19.796198   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority
Oct 25 19:14:20 ip-172-31-55-29.us-west-2.compute.internal atomic-openshift-master-controllers[25469]: E1025 19:14:20.451152   25469 signature_import_controller.go:109] error syncing image sha256:4665187e62fb995c6001d398df50f5730e268faccd3ef9e398dbdcb5e6db6937, it will be retried: pinging docker registry returned: Get https://docker-registry.default.svc:5000/v2/: x509: certificate signed by unknown authority


Version-Release number of selected component (if applicable):
openshift v3.7.0-0.178.0
kubernetes v1.7.6+a08f5eeb62
etcd 3.2.8

How reproducible:
Always, after creating dancer quickstart apps

Steps to Reproduce:
1. oc new-project test
2. oc new-app --template=dancer-mysql-example

Actual results:
Logs are spammed at loglevel 2

Expected results:
Logs should not have spam at loglevel 2

Additional info:

Comment 1 Michal Fojtik 2017-10-26 08:58:18 UTC
Fixed here: https://github.com/openshift/origin/pull/16947

Comment 2 Mike Fiedler 2017-11-10 13:40:46 UTC
Verified on 3.7.5 - these messages no longer pop during the cluster horizontal test.

Comment 5 errata-xmlrpc 2017-12-18 13:23:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3464


Note You need to log in before you can comment on or make changes to this bug.