Bug 1506441 - Implicit conflicts between mariadb and mariadb-connector-c in Fedora 27
Summary: Implicit conflicts between mariadb and mariadb-connector-c in Fedora 27
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb-connector-c
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-26 04:57 UTC by Mattias Ellert
Modified: 2020-09-10 13:20 UTC (History)
6 users (show)

Fixed In Version: mariadb-connector-c-3.0.2-14.fc27 mariadb-connector-c-3.0.2-14.fc25 mariadb-connector-c-3.0.2-14.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-11 03:10:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Mattias Ellert 2017-10-26 04:57:38 UTC
Description of problem:

https://fedoraproject.org/wiki/Packaging:Conflicts#Implicit_Conflicts says

"Keep in mind that implicit conflicts are NEVER acceptable. If your package conflicts with another package, then you must either resolve the conflict, or mark it with Conflicts:."

Trying to install both packages on Fedora 27 fails due to implicit conflicts:

Running transaction check
Transaction check succeeded.
Running transaction test
Error: Transaction check error:
  file /usr/lib64/mysql/plugin/dialog.so conflicts between attempted installs of mariadb-common-3:10.2.9-3.fc27.x86_64 and mariadb-connector-c-3.0.2-11.fc27.x86_64
  file /usr/lib64/mysql/plugin/mysql_clear_password.so conflicts between attempted installs of mariadb-common-3:10.2.9-3.fc27.x86_64 and mariadb-connector-c-3.0.2-11.fc27.x86_64
  file /usr/lib64/mysql/libmariadb.so.3 conflicts between attempted installs of mariadb-libs-3:10.2.9-3.fc27.x86_64 and mariadb-connector-c-3.0.2-11.fc27.x86_64
  file /usr/bin/mariadb_config conflicts between attempted installs of mariadb-connector-c-devel-3.0.2-11.fc27.x86_64 and mariadb-devel-3:10.2.9-3.fc27.x86_64
  file /usr/bin/mysql_config conflicts between attempted installs of mariadb-connector-c-devel-3.0.2-11.fc27.x86_64 and mariadb-devel-3:10.2.9-3.fc27.x86_64
  file /usr/include/mysql/mariadb_com.h conflicts between attempted installs of mariadb-connector-c-devel-3.0.2-11.fc27.x86_64 and mariadb-devel-3:10.2.9-3.fc27.x86_64
  file /usr/include/mysql/mariadb_version.h conflicts between attempted installs of mariadb-connector-c-devel-3.0.2-11.fc27.x86_64 and mariadb-devel-3:10.2.9-3.fc27.x86_64
  file /usr/include/mysql/mysql_version.h conflicts between attempted installs of mariadb-connector-c-devel-3.0.2-11.fc27.x86_64 and mariadb-devel-3:10.2.9-3.fc27.x86_64
  file /usr/include/mysql/mysqld_error.h conflicts between attempted installs of mariadb-connector-c-devel-3.0.2-11.fc27.x86_64 and mariadb-devel-3:10.2.9-3.fc27.x86_64

Packages in Fedora must either be parallel installable or marked with Conflicts tags. Failing installation due to implicit conflicts is not acceptable according to the guidelines.

Version-Release number of selected component (if applicable):
mariadb-connector-c-3.0.2-11.fc27
mariadb-10.2.9-3.fc27

How reproducible:
Always

Steps to Reproduce:
1. mock --root fedora-27-x86_64 --enablerepo updates-testing --install mariadb-devel mariadb-connector-c-devel

Actual results:
Installation fails due to implicit conflicts

Expected results:
Installation should succeed, or fail due to explicit Conflicts tags.

Additional info:
The packages are parallel installable both in Fedora 26 and in Fedora 28 (rawhide), only Fedora 27 is broken.

Comment 1 Michal Schorm 2017-10-26 10:19:39 UTC
Acknowledged.

It should conflict.
I'm testing right now an update for connector-c, so I'll ad the fix to it.

Thanks for heads up for the "Conflicts:"!

Comment 2 Harald Reindl 2017-10-27 14:41:06 UTC
what is the whole point of "mariadb-connector-c" at all when you have mmariadb-libs and mariadb-libs-devel which provides the client libraries?

Comment 3 Fedora Update System 2017-10-31 13:40:10 UTC
mariadb-connector-c-3.0.2-14.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d0a7b146a1

Comment 4 Fedora Update System 2017-10-31 13:40:31 UTC
mariadb-connector-c-3.0.2-14.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6a5f895018

Comment 5 Fedora Update System 2017-10-31 13:40:45 UTC
mariadb-connector-c-3.0.2-14.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e18ea35fe3

Comment 6 Fedora Update System 2017-10-31 19:10:46 UTC
mariadb-connector-c-3.0.2-14.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6a5f895018

Comment 7 Fedora Update System 2017-11-01 16:57:50 UTC
mariadb-connector-c-3.0.2-14.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e18ea35fe3

Comment 8 Fedora Update System 2017-11-01 17:22:43 UTC
mariadb-connector-c-3.0.2-14.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d0a7b146a1

Comment 9 Fedora Update System 2017-11-11 03:10:09 UTC
mariadb-connector-c-3.0.2-14.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-11-11 15:47:21 UTC
mariadb-connector-c-3.0.2-14.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-11-11 20:06:32 UTC
mariadb-connector-c-3.0.2-14.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Mats Wichmann 2020-09-10 13:08:49 UTC
This is closed long ago, but has started happening again:

file /usr/include/mysql/mariadb_rpl.h conflicts between attempted installs of mariadb-devel-3:10.3.22-1.fc31.x86_64 and mariadb-connector-c-devel-3.1.9-5.fc31.x86_64

Comment 13 Michal Schorm 2020-09-10 13:14:34 UTC
Yeah, and the BZ was reported and the fix is already available:
https://bodhi.fedoraproject.org/updates/FEDORA-2020-3868184fd2
try it and give it karma :)

Comment 14 Harald Reindl 2020-09-10 13:20:56 UTC
i still don't get the existence of this package at all

[root@srv-rhsoft:~]$ rpm -q --filesbypkg mariadb-libs | grep -v /usr/share | grep -v build-id
mariadb-libs              /etc/ld.so.conf.d/mariadb-x86_64.conf
mariadb-libs              /usr/lib64/mysql
mariadb-libs              /usr/lib64/mysql/libmariadb.so.3

[root@srv-rhsoft:~]$ rpm -q --info mariadb-libs
Name        : mariadb-libs
Epoch       : 13
Version     : 10.3.24
Release     : 0.fc32.20200822.rh.sandybridge
Architecture: x86_64
Install Date: Sa 22 Aug 2020 20:31:53 CEST
Group       : Unspecified
Size        : 2396896
License     : GPLv2
Signature   : (none)
Source RPM  : mariadb-10.3.24-0.fc32.20200822.rh.sandybridge.src.rpm
Build Date  : Sa 22 Aug 2020 14:56:15 CEST
Build Host  : testserver.rhsoft.net
Packager    : Reindl Harald <h.reindl@thelounge.net>

%package           libs
Summary:           The shared libraries required for MariaDB clients
Provides:          mysql-libs = %{epoch}:%{version}-%{release}, mysql-libs%{?_isa} = %{epoch}:%{version}-%{release}, mariadb-connector-c = %{epoch}:%{version}-%{release}, mariadb-connector-c%{?_isa} = %{epoch}:%{version}-%{release}
Obsoletes:         mysql-libs < 1000, community-mysql-libs < 1000


Note You need to log in before you can comment on or make changes to this bug.