Bug 1506445 - Broken package due to wrong dependency: python-ipaddress
Summary: Broken package due to wrong dependency: python-ipaddress
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-pyspf
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Wouters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1506881 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-10-26 05:14 UTC by Alexander Kjær
Modified: 2017-11-16 15:49 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-11-16 15:49:01 UTC


Attachments (Terms of Use)

Description Alexander Kjær 2017-10-26 05:14:33 UTC
Description of problem:
Newest package update installs python-ipaddress which has a known problem as described in https://bugzilla.redhat.com/show_bug.cgi?id=1230373

Version-Release number of selected component (if applicable):
pypolicyd-spf-1.3.2-2.el7

How reproducible:
Install update.

Steps to Reproduce:
1. Install update pypolicyd-spf-1.3.2-2
2. Package installs new dependency python-ipaddress
3. Breaks SPF checks and your MTA.

Actual results:
See Additional info.

Expected results:
Process SPF checks.

Additional info:
Oct 26 05:10:02 mail policyd-spf[5204]: Traceback (most recent call last):
Oct 26 05:10:02 mail policyd-spf[5204]:  File "/usr/libexec/postfix/policyd-spf", line 707, in <module>
Oct 26 05:10:02 mail policyd-spf[5204]:    instance_dict, configData, peruser)
Oct 26 05:10:02 mail policyd-spf[5204]:  File "/usr/libexec/postfix/policyd-spf", line 419, in _spfcheck
Oct 26 05:10:02 mail policyd-spf[5204]:    res = spf.check2(ip, helo_fake_sender, helo, querytime=configData.get('Lookup_Time'))
Oct 26 05:10:02 mail policyd-spf[5204]:  File "/usr/lib/python2.7/site-packages/spf.py", line 297, in check2
Oct 26 05:10:02 mail policyd-spf[5204]:    receiver=receiver,timeout=timeout,verbose=verbose,querytime=querytime).check()
Oct 26 05:10:02 mail policyd-spf[5204]:  File "/usr/lib/python2.7/site-packages/spf.py", line 378, in __init__
Oct 26 05:10:02 mail policyd-spf[5204]:    self.set_ip(i)
Oct 26 05:10:02 mail policyd-spf[5204]:  File "/usr/lib/python2.7/site-packages/spf.py", line 405, in set_ip
Oct 26 05:10:02 mail policyd-spf[5204]:    self.ipaddr = ipaddress.ip_address(i)
Oct 26 05:10:02 mail policyd-spf[5204]:  File "/usr/lib/python2.7/site-packages/ipaddress.py", line 163, in ip_address
Oct 26 05:10:02 mail policyd-spf[5204]:    ' a unicode object?' % address)
Oct 26 05:10:02 mail policyd-spf[5204]: AddressValueError: '89.221.243.57' does not appear to be an IPv4 or IPv6 address. Did you pass in a bytes (str in Python 2) instead of a unicode object?
Oct 26 05:10:02 mail postfix/spawn[26900]: warning: command /usr/libexec/postfix/policyd-spf exit status 1
Oct 26 05:10:02 mail postfix/smtpd[2635]: warning: premature end-of-input on private/policyd-spf while reading input attribute name

Comment 1 Bojan Smojver 2017-10-26 06:06:43 UTC
Seems like python-pyspf needs to be patched as well, just like we did in Fedora. Assigning to that package.

Comment 2 Bojan Smojver 2017-10-26 06:11:33 UTC
Note for the maintainers of python-pyspf:

Essentially, we want to merge branch f22 into epel7, commit, rebuild and submit to bodhi.

Comment 3 Bojan Smojver 2017-10-27 05:00:17 UTC
*** Bug 1506881 has been marked as a duplicate of this bug. ***

Comment 4 Aleksandrs Ļedovskis 2017-10-29 06:15:06 UTC
Can confirm breakage. As a workaround had to remove python-ipaddress and pypolicyd packages and manually reinstall/versionlock to pypolicyd-spf-1.3.2-1 (RPM found at http://rpm.pbone.net/index.php3/stat/4/idpl/40160295/dir/redhat_el_7/com/pypolicyd-spf-1.3.2-1.el7.noarch.rpm.html)

Comment 5 Fedora Update System 2017-10-30 16:57:18 UTC
python-pyspf-2.0.11-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-aded0ed528

Comment 6 Fedora Update System 2017-10-31 02:35:29 UTC
pypolicyd-spf-1.3.2-3.el7 python-pyspf-2.0.11-4.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-aded0ed528

Comment 7 Fedora Update System 2017-11-01 17:13:00 UTC
pypolicyd-spf-1.3.2-3.el7, python-pyspf-2.0.11-4.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-aded0ed528

Comment 8 Fedora Update System 2017-11-01 19:27:52 UTC
pypolicyd-spf-1.3.2-5.el7 python-pyspf-2.0.11-5.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-aded0ed528

Comment 9 Fedora Update System 2017-11-03 14:10:48 UTC
pypolicyd-spf-1.3.2-5.el7, python-pyspf-2.0.11-5.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-aded0ed528

Comment 10 Fedora Update System 2017-11-16 15:49:01 UTC
pypolicyd-spf-1.3.2-5.el7, python-pyspf-2.0.11-5.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.