This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 150645 - Install can't proceed past invalid partition table error
Install can't proceed past invalid partition table error
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-03-09 01:58 EST by Deron Meranda
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-28 09:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Deron Meranda 2005-03-09 01:58:19 EST
Description of problem:
I'm attempting a fresh install onto a hard drive which has a corrupted
pre-existing partition table (see bottom of this post for details on the type of
corruption).  During the early install when Disk Druid is entered an error
dialog is displayed that says

 "Invalid Partition Table on /dev/hda - wrong signature 0"

and I'm only given the option Ignore or Cancel.  I don't want to keep any data
on the disk and want to just reformat it as if new, but can find no way to make
the install just write a brand new blank partition table; the error dialog never
goes away.

I then switched to the console shell and tried running parted manually.  When
trying to display the partition table it complains with the same error message.
 I then tried fdisk, and it gave the message

 "warning: invalid flag 0x0000 of partition table 5 will be corrected by w(rite)"

It appears as if fdisk will repair/reformat the partition table, and I know I
could do a "dd if=/dev/zero of=/dev/hda bs=2014 count=2" trick.  But it would
seem to me that the graphical installer, when noticing that the partition table
is corrupt, should offer a way to proceed and/or rebuild a new blank partition
table.  I think this may be a limitation of parted?

Version-Release number of selected component (if applicable):
Fedora Core 3 (i386)
ALSO same behavior on CentOS 4.0 (aka RHEL 4.0)

How reproducible:
Always (given that you start with a corrupt partition table)

Steps to Reproduce:
1. Start with a hard disk with a slightly corrupt partition table
  (one which is basically correct except for an invalid partition flag)
2. Attempt an install using Disk Druid -or- use parted manually
  
Actual results:
No way to correct or reformat partition table (short of escaping to a shell and
using dd).

Expected results:
GUI installer should offer to rebuild a new partition table,
especially on an install (not upgrade).


Extra information...How the partition table became corrupted.
I originally had an extended partition that looked something like:
   /dev/hda4  Type 0x0f - W95 Ext'd (LBA)
   /dev/hda5  Type 0x83 - Linux
I wanted to erase that partition prior to a new install to make sure
previous convidential data was destroyed, so under the old OS I ran
   dd if=/dev/zero of=/dev/hda4 bs=1024
This had the effect of also creating an invalid logical partition #5
since the logical partition information had been overwritten with 0's.
But the primary partition table was still perfectly intact.
Comment 1 Chris Lumens 2005-09-23 13:51:52 EDT
Please try upgrading to the latest release and seeing if you still experience
problems.
Comment 2 John Thacker 2006-04-28 09:18:44 EDT
No response from reporter.  FC3 is the responsibility of Fedora Legacy, 
and this is not a security issue.
If it can be reproduced on FC4 or FC5, please reopen.

Note You need to log in before you can comment on or make changes to this bug.